summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 18:46:51 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 18:48:00 +0000
commit53301b81f62359dc647e8f1fe22f0e1b456e818f (patch)
tree101bf07033c4aad06305a52a691b7a36c3ce143c
parentIgnore work directories (diff)
downloadports-53301b81f62359dc647e8f1fe22f0e1b456e818f.tar.gz
ports-53301b81f62359dc647e8f1fe22f0e1b456e818f.zip
Add pounce port
-rw-r--r--irc/pounce/Makefile25
-rw-r--r--irc/pounce/distinfo3
-rw-r--r--irc/pounce/pkg-descr5
-rw-r--r--irc/pounce/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/irc/pounce/Makefile b/irc/pounce/Makefile
new file mode 100644
index 0000000..6a5c656
--- /dev/null
+++ b/irc/pounce/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME=	pounce
+DISTVERSION=	1.3p1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/irc/pounce/distinfo b/irc/pounce/distinfo
new file mode 100644
index 0000000..5c271d9
--- /dev/null
+++ b/irc/pounce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596739669
+SHA256 (pounce-1.3p1.tar.gz) = 6093c25233315d3d926db131219d1bb93d3714746c9eb8437e45e28a703d4873
+SIZE (pounce-1.3p1.tar.gz) = 40679
diff --git a/irc/pounce/pkg-descr b/irc/pounce/pkg-descr
new file mode 100644
index 0000000..68679a2
--- /dev/null
+++ b/irc/pounce/pkg-descr
@@ -0,0 +1,5 @@
+pounce is a multi-client, TLS-only IRC bouncer. It takes a simple
+approach, using a multiple-consumer ring buffer and the IRCv3.2
+server-time extension to communicate with clients.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/irc/pounce/pkg-plist b/irc/pounce/pkg-plist
new file mode 100644
index 0000000..a0de441
--- /dev/null
+++ b/irc/pounce/pkg-plist
@@ -0,0 +1,8 @@
+@dir /var/run/calico
+@dir etc/pounce
+bin/calico
+bin/pounce
+etc/rc.d/calico
+etc/rc.d/pounce
+man/man1/calico.1.gz
+man/man1/pounce.1.gz