summary refs log tree commit diff
path: root/irc/pounce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/pounce/Makefile')
-rw-r--r--irc/pounce/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/irc/pounce/Makefile b/irc/pounce/Makefile
new file mode 100644
index 0000000..6a5c656
--- /dev/null
+++ b/irc/pounce/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME=	pounce
+DISTVERSION=	1.3p1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>