summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-10-02 02:04:38 +0000
committerJune McEnroe <june@causal.agency>2021-10-02 02:04:38 +0000
commit69c0080d3614d0a05b38e49e21d7e0eaa431b629 (patch)
tree2c9ac817a014ceb68bc75a09354b6f1e13636055
parentOpenBSD: Add port for pounce (diff)
downloadports-69c0080d3614d0a05b38e49e21d7e0eaa431b629.tar.gz
ports-69c0080d3614d0a05b38e49e21d7e0eaa431b629.zip
OpenBSD: Add port for litterbox
-rw-r--r--OpenBSD/net/litterbox/Makefile27
-rw-r--r--OpenBSD/net/litterbox/distinfo2
-rw-r--r--OpenBSD/net/litterbox/pkg/DESCR4
-rw-r--r--OpenBSD/net/litterbox/pkg/PLIST7
4 files changed, 40 insertions, 0 deletions
diff --git a/OpenBSD/net/litterbox/Makefile b/OpenBSD/net/litterbox/Makefile
new file mode 100644
index 0000000..d82b5fd
--- /dev/null
+++ b/OpenBSD/net/litterbox/Makefile
@@ -0,0 +1,27 @@
+# $OpenBSD$
+
+COMMENT =	IRC logger
+DISTNAME =	litterbox-1.8
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/litterbox/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+WANTLIB =		c sqlite3 tls
+LIB_DEPENDS =	databases/sqlite3
+
+MASTER_SITES =		https://git.causal.agency/litterbox/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+CFLAGS +=	-I${LOCALBASE}/include
+MAKE_FLAGS +=	LDFLAGS=-L${LOCALBASE}/lib
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/litterbox/distinfo b/OpenBSD/net/litterbox/distinfo
new file mode 100644
index 0000000..d8a3759
--- /dev/null
+++ b/OpenBSD/net/litterbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (litterbox-1.8.tar.gz) = VL68N1DzkIE6NyDrAwGsTYUrMMt7dgWxeO1ZqlFohVI=
+SIZE (litterbox-1.8.tar.gz) = 36827
diff --git a/OpenBSD/net/litterbox/pkg/DESCR b/OpenBSD/net/litterbox/pkg/DESCR
new file mode 100644
index 0000000..c50791d
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/DESCR
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger.  It logs events from IRC in a
+SQLite database, indexing messages for full-text search.  It is
+intended for use with the IRC bouncer pounce, but can also be used
+independently as a logging bot.
diff --git a/OpenBSD/net/litterbox/pkg/PLIST b/OpenBSD/net/litterbox/pkg/PLIST
new file mode 100644
index 0000000..606da42
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/PLIST
@@ -0,0 +1,7 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/litterbox
+@bin bin/scoop
+@bin bin/unscoop
+@man man/man1/litterbox.1
+@man man/man1/scoop.1
+@man man/man1/unscoop.1