summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-10-02 01:51:29 +0000
committerJune McEnroe <june@causal.agency>2021-10-02 01:51:29 +0000
commitad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61 (patch)
treea74d810f757975c4aab93dbe4cde18d9c1afd81d
parentOpenBSD: Add port for catsit (diff)
downloadports-ad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61.tar.gz
ports-ad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61.zip
OpenBSD: Add port for pounce
-rw-r--r--OpenBSD/net/pounce/Makefile26
-rw-r--r--OpenBSD/net/pounce/distinfo2
-rw-r--r--OpenBSD/net/pounce/pkg/DESCR7
-rw-r--r--OpenBSD/net/pounce/pkg/PLIST5
4 files changed, 40 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..892a415
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,26 @@
+# $OpenBSD$
+
+COMMENT =	IRC bouncer
+DISTNAME =	pounce-2.5
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+MAKE_FLAGS +=	LDADD.crypt=
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce/distinfo b/OpenBSD/net/pounce/distinfo
new file mode 100644
index 0000000..b7c857d
--- /dev/null
+++ b/OpenBSD/net/pounce/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-2.5.tar.gz) = w/iPheprMhHXe4GTcxcEywGHGu5odi0va16bEC+D0K0=
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/OpenBSD/net/pounce/pkg/DESCR b/OpenBSD/net/pounce/pkg/DESCR
new file mode 100644
index 0000000..6858864
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/DESCR
@@ -0,0 +1,7 @@
+pounce is a multi-client, TLS-only IRC bouncer.  It maintains a
+persistent connection to an IRC server, acting as a proxy and buffer
+for a number of clients.  When a client connects, any messages
+received since it last disconnected will be relayed to it.  Unlike
+some other bouncers, pounce uses a single buffer for all IRC messages,
+which acts as a queue from which each client reads messages
+independently.
diff --git a/OpenBSD/net/pounce/pkg/PLIST b/OpenBSD/net/pounce/pkg/PLIST
new file mode 100644
index 0000000..9876d19
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/PLIST
@@ -0,0 +1,5 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/calico
+@bin bin/pounce
+@man man/man1/calico.1
+@man man/man1/pounce.1