summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-10-02 01:43:16 +0000
committerJune McEnroe <june@causal.agency>2021-10-02 01:43:16 +0000
commit8700de424e03b4fabc6a96b7cd235bae4d316310 (patch)
tree9536d5cf49204d70094a9b9f23b149898b36b548
parentOpenBSD: Build and install git{,-http-backend} with cgit (diff)
downloadports-8700de424e03b4fabc6a96b7cd235bae4d316310.tar.gz
ports-8700de424e03b4fabc6a96b7cd235bae4d316310.zip
OpenBSD: Add port for catsit
-rw-r--r--OpenBSD/sysutils/catsit/Makefile25
-rw-r--r--OpenBSD/sysutils/catsit/distinfo2
-rw-r--r--OpenBSD/sysutils/catsit/pkg/DESCR5
-rw-r--r--OpenBSD/sysutils/catsit/pkg/PLIST11
4 files changed, 43 insertions, 0 deletions
diff --git a/OpenBSD/sysutils/catsit/Makefile b/OpenBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..a26f6a8
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/Makefile
@@ -0,0 +1,25 @@
+# $OpenBSD$
+
+COMMENT =	process supervisor
+DISTNAME =	catsit-1.4
+CATEGORIES =	sysutils
+HOMEPAGE =	https://git.causal.agency/catsit/about/
+MAINTAINER =		june@causal.agency
+
+# AGPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c
+
+MASTER_SITES =		https://git.causal.agency/catsit/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/sysutils/catsit/distinfo b/OpenBSD/sysutils/catsit/distinfo
new file mode 100644
index 0000000..f88d44d
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (catsit-1.4.tar.gz) = gybvLpMSCSzfEhxro997k/gij8pbUU5rBbmMhIU15Ng=
+SIZE (catsit-1.4.tar.gz) = 24341
diff --git a/OpenBSD/sysutils/catsit/pkg/DESCR b/OpenBSD/sysutils/catsit/pkg/DESCR
new file mode 100644
index 0000000..3b65708
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/pkg/DESCR
@@ -0,0 +1,5 @@
+catsit is a process supervisor for FreeBSD and OpenBSD.  The catsitd
+daemon spawns processes for a list of services, redirects their
+output to syslog, and restarts the processes when they exit according
+to their exit status.  Exponential backoff is applied to automatic
+restarts.
diff --git a/OpenBSD/sysutils/catsit/pkg/PLIST b/OpenBSD/sysutils/catsit/pkg/PLIST
new file mode 100644
index 0000000..bf46141
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/pkg/PLIST
@@ -0,0 +1,11 @@
+@comment $OpenBSD: PLIST,v$
+@rcscript ${RCDIR}/catsitd
+@bin bin/catsit-timer
+@bin bin/catsit-watch
+@man man/man1/catsit-timer.1
+@man man/man1/catsit-watch.1
+@man man/man5/catsit.conf.5
+@man man/man8/catsit.8
+@man man/man8/catsitd.8
+sbin/catsit
+@bin sbin/catsitd