summary refs log tree commit diff
path: root/OpenBSD/sysutils/catsit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/sysutils/catsit/Makefile')
-rw-r--r--OpenBSD/sysutils/catsit/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/OpenBSD/sysutils/catsit/Makefile b/OpenBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..a26f6a8
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/Makefile
@@ -0,0 +1,25 @@
+# $OpenBSD$
+
+COMMENT =	process supervisor
+DISTNAME =	catsit-1.4
+CATEGORIES =	sysutils
+HOMEPAGE =	https://git.causal.agency/catsit/about/
+MAINTAINER =		june@causal.agency
+
+# AGPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c
+
+MASTER_SITES =		https://git.causal.agency/catsit/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>