summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2022-04-05 23:10:31 +0000
committerJune McEnroe <june@causal.agency>2022-04-05 23:10:42 +0000
commita424d55e0b97351d59bf39c736a40e66de2bc423 (patch)
tree0a3148f503596849a2b7a8f67532af1b1959dc97
parentOpenBSD: Add pounce-notify port (diff)
downloadports-a424d55e0b97351d59bf39c736a40e66de2bc423.tar.gz
ports-a424d55e0b97351d59bf39c736a40e66de2bc423.zip
OpenBSD: Add pounce-palaver port
-rw-r--r--OpenBSD/net/pounce-palaver/Makefile35
-rw-r--r--OpenBSD/net/pounce-palaver/distinfo2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/DESCR2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/PLIST2
4 files changed, 41 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce-palaver/Makefile b/OpenBSD/net/pounce-palaver/Makefile
new file mode 100644
index 0000000..f7c10a2
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/Makefile
@@ -0,0 +1,35 @@
+COMMENT =	Palaver push notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-palaver-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c curl sqlite3 tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/palaver
+
+LIB_DEPENDS =	databases/sqlite3 net/curl
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-palaver/distinfo b/OpenBSD/net/pounce-palaver/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-palaver/pkg/DESCR b/OpenBSD/net/pounce-palaver/pkg/DESCR
new file mode 100644
index 0000000..f65a58d
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/DESCR
@@ -0,0 +1,2 @@
+pounce-palaver provides push notifications for the Palaver IRC app
+via pounce.
diff --git a/OpenBSD/net/pounce-palaver/pkg/PLIST b/OpenBSD/net/pounce-palaver/pkg/PLIST
new file mode 100644
index 0000000..d5efc2c
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-palaver
+@man man/man1/pounce-palaver.1