summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2022-04-05 23:00:02 +0000
committerJune McEnroe <june@causal.agency>2022-04-05 23:10:41 +0000
commiteee90a1635b2463527e0448d8dd0dc8410411b5a (patch)
treeee234190a748787ecd4a0649823a208436bd92d3
parentOpenBSD: sync pounce port with upstream (diff)
downloadports-eee90a1635b2463527e0448d8dd0dc8410411b5a.tar.gz
ports-eee90a1635b2463527e0448d8dd0dc8410411b5a.zip
OpenBSD: Add pounce-notify port
-rw-r--r--OpenBSD/net/pounce-notify/Makefile33
-rw-r--r--OpenBSD/net/pounce-notify/distinfo2
-rw-r--r--OpenBSD/net/pounce-notify/pkg/DESCR1
-rw-r--r--OpenBSD/net/pounce-notify/pkg/PLIST2
4 files changed, 38 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce-notify/Makefile b/OpenBSD/net/pounce-notify/Makefile
new file mode 100644
index 0000000..f472957
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/Makefile
@@ -0,0 +1,33 @@
+COMMENT =	notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-notify-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/notify
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-notify/distinfo b/OpenBSD/net/pounce-notify/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-notify/pkg/DESCR b/OpenBSD/net/pounce-notify/pkg/DESCR
new file mode 100644
index 0000000..dfd2aec
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/DESCR
@@ -0,0 +1 @@
+pounce-notify provides generic notifications for pounce.
diff --git a/OpenBSD/net/pounce-notify/pkg/PLIST b/OpenBSD/net/pounce-notify/pkg/PLIST
new file mode 100644
index 0000000..dd7566e
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-notify
+@man man/man1/pounce-notify.1
ver-highlight'> I hate these things and also this one sucks. 2021-09-21Use Z_FILTERED strategyJune McEnroe 2021-09-21Recalculate various lengths only as neededJune McEnroe This actually speeds things up quite a bit, saving roughly a second on a big PNG screenshot. Almost all the remaining time is spent in deflate. 2021-09-21Rewrite pngo, add explicit optionsJune McEnroe Interesting to see how my code habits have changed. 2021-09-16Fix /* **/ comment matchingJune McEnroe 2021-09-15Remove typer, add downgrade to READMEJune McEnroe 2021-09-15Set bot mode on downgradeJune McEnroe 2021-09-15Enter capsicum in downgradeJune McEnroe 2021-09-15Factor out common parts of downgrade messagesJune McEnroe Also bump the message cap to 1024 because that is ostensibly useful for replying to older messages. 2021-09-14Add downgrade IRC botJune McEnroe 2021-09-14Sort by title if authors matchJune McEnroe There are probably better things to sort by but title definitely always exists. 2021-09-13Swap-remove tags as they're foundJune McEnroe This makes it even faster. From ~1s on a sqlite3.c amalgamation to ~0.85s. 2021-09-12Replace htagml regex with strncmpJune McEnroe Since ctags only ever produces regular expressions of the form /^re$/ or /^re/ with no other special characters, instead unescape the pattern and simply use strncmp. Running on a sqlite3.c amalgamation, the regex version takes ~37s while the strncmp version takes ~1s, producing identical output. Big win! 2021-09-11Also defer printing comment for lone close-parensJune McEnroe 2021-09-10Publish "git-comment"June McEnroe 2021-09-10Add git comment --pretty optionJune McEnroe 2021-09-08Defer printing comment if line is blank or closing braceJune McEnroe This fixes badly indented comments. 2021-09-08Up default min-repeat to 30 linesJune McEnroe 2021-09-08Handle dirty lines in git-commentJune McEnroe 2021-09-08Document and install git-commentJune McEnroe 2021-09-08Add repeat and all options to git-commentJune McEnroe 2021-09-08Add group threshold to git-commentJune McEnroe