summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 18:52:07 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 18:52:07 +0000
commita51cc22f5d7b147b14c1ba6a6498fc6d097b40b5 (patch)
treea5372b255dccbddf7ccd23aeb167d89914200317
parentAdd catgirl port (diff)
downloadports-a51cc22f5d7b147b14c1ba6a6498fc6d097b40b5.tar.gz
ports-a51cc22f5d7b147b14c1ba6a6498fc6d097b40b5.zip
Add cgit-patched port
-rw-r--r--devel/cgit-patched/Makefile71
-rw-r--r--devel/cgit-patched/distinfo5
-rw-r--r--devel/cgit-patched/files/pkg-message.in18
-rw-r--r--devel/cgit-patched/pkg-descr4
-rw-r--r--devel/cgit-patched/pkg-plist21
5 files changed, 119 insertions, 0 deletions
diff --git a/devel/cgit-patched/Makefile b/devel/cgit-patched/Makefile
new file mode 100644
index 0000000..670897e
--- /dev/null
+++ b/devel/cgit-patched/Makefile
@@ -0,0 +1,71 @@
+# $FreeBSD: head/devel/cgit/Makefile 523699 2020-01-21 01:37:59Z meta $
+
+PORTNAME=	cgit-patched
+PORTVERSION=	1.2.3p3
+CONFLICTS_INSTALL=	cgit
+CATEGORIES=	devel www
+MASTER_SITES=	https://git.causal.agency/cgit/snapshot/:cgit \
+		KERNEL_ORG/software/scm/git:git
+DISTFILES=	cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
+		git-${GIT_VERSION}${EXTRACT_SUFX}:git
+DISTNAME=	cgit-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Fast, lightweight web frontend for Git repositories
+
+LICENSE=	GPLv2
+LICENSE_FILE=	${WRKSRC}/COPYING
+
+TEST_DEPENDS=	msgfmt:devel/gettext-tools
+
+GIT_VERSION=	2.25.0
+USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
+CPE_VENDOR=	lars_hjemli
+USE_PERL5=	test
+SHEBANG_FILES=	filters/email-gravatar.py \
+		filters/html-converters/md2html \
+		filters/html-converters/rst2html \
+		filters/syntax-highlighting.py
+WWWDIR=	${PREFIX}/www/cgit
+
+CFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
+MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
+		prefix=${PREFIX} NO_GETTEXT=1 NO_LUA=1 NO_R_TO_GCC_LINKER=1 V=1
+
+SUB_FILES=	pkg-message
+
+PORTDOCS=	cgitrc.5.txt
+
+OPTIONS_DEFINE=	DOCS ASCIIDOC
+OPTIONS_DEFAULT=	ASCIIDOC
+OPTIONS_SUB=	yes
+
+ASCIIDOC_DESC=	Use asciidoc to preprocess man page
+ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
+
+post-extract:
+	@${RMDIR} ${WRKSRC}/git
+	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
+
+post-patch:
+	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
+		${WRKSRC}/Makefile
+
+	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
+		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
+		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
+		${WRKSRC}/git/Makefile
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
+
+post-install-DOCS-on:
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-ASCIIDOC-on:
+	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
+	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/devel/cgit-patched/distinfo b/devel/cgit-patched/distinfo
new file mode 100644
index 0000000..0a951b5
--- /dev/null
+++ b/devel/cgit-patched/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1595538673
+SHA256 (cgit-1.2.3p3.tar.gz) = ef8859b47c150ceeff27d577a3ff1d2dc5644468f532bc4e660d47feae26a646
+SIZE (cgit-1.2.3p3.tar.gz) = 111767
+SHA256 (git-2.25.0.tar.gz) = a98c9b96d91544b130f13bf846ff080dda2867e77fe08700b793ab14ba5346f6
+SIZE (git-2.25.0.tar.gz) = 9023390
diff --git a/devel/cgit-patched/files/pkg-message.in b/devel/cgit-patched/files/pkg-message.in
new file mode 100644
index 0000000..0190639
--- /dev/null
+++ b/devel/cgit-patched/files/pkg-message.in
@@ -0,0 +1,18 @@
+[
+{ type: install
+  message: <<EOM
+cgit has been successfully installed.
+
+To enable cgit in Apache, use something like the following:
+
+  <Directory "%%WWWDIR%%/">
+      AllowOverride None
+      Options +ExecCGI
+      Require all granted 
+  </Directory>
+
+Documentation and sample configuration can be found
+in %%DOCSDIR%%/cgitrc.5.txt.
+EOM
+}
+]
diff --git a/devel/cgit-patched/pkg-descr b/devel/cgit-patched/pkg-descr
new file mode 100644
index 0000000..1a9d828
--- /dev/null
+++ b/devel/cgit-patched/pkg-descr
@@ -0,0 +1,4 @@
+cgit is a fast web interface for the Git SCM, using a built-in cache to
+decrease server I/O pressure.
+
+WWW: https://git.zx2c4.com/cgit/about/
diff --git a/devel/cgit-patched/pkg-plist b/devel/cgit-patched/pkg-plist
new file mode 100644
index 0000000..765565f
--- /dev/null
+++ b/devel/cgit-patched/pkg-plist
@@ -0,0 +1,21 @@
+lib/cgit/filters/about-formatting.sh
+lib/cgit/filters/commit-links.sh
+lib/cgit/filters/email-gravatar.lua
+lib/cgit/filters/email-gravatar.py
+lib/cgit/filters/email-libravatar.lua
+lib/cgit/filters/file-authentication.lua
+lib/cgit/filters/gentoo-ldap-authentication.lua
+lib/cgit/filters/html-converters/man2html
+lib/cgit/filters/html-converters/md2html
+lib/cgit/filters/html-converters/rst2html
+lib/cgit/filters/html-converters/txt2html
+lib/cgit/filters/owner-example.lua
+lib/cgit/filters/simple-authentication.lua
+lib/cgit/filters/syntax-highlighting.py
+lib/cgit/filters/syntax-highlighting.sh
+%%ASCIIDOC%%man/man5/cgitrc.5.gz
+%%WWWDIR%%/cgit.cgi
+%%WWWDIR%%/cgit.css
+%%WWWDIR%%/cgit.png
+%%WWWDIR%%/favicon.ico
+%%WWWDIR%%/robots.txt