summary refs log tree commit diff
path: root/OpenBSD/net/pounce-notify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net/pounce-notify/Makefile')
-rw-r--r--OpenBSD/net/pounce-notify/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce-notify/Makefile b/OpenBSD/net/pounce-notify/Makefile
new file mode 100644
index 0000000..f472957
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/Makefile
@@ -0,0 +1,33 @@
+COMMENT =	notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-notify-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/notify
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>