summary refs log tree commit diff
path: root/FreeBSD/irc
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
committerJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
commit97eb0074b135b2636d84ff503988e3d76803ddcc (patch)
treeb7bf84cab6a5df4035634f60e4b92ed8dbcf8c32 /FreeBSD/irc
parentUpdate catsit to 1.4 (diff)
downloadports-97eb0074b135b2636d84ff503988e3d76803ddcc.tar.gz
ports-97eb0074b135b2636d84ff503988e3d76803ddcc.zip
Move FreeBSD ports under FreeBSD directory
Diffstat (limited to 'FreeBSD/irc')
-rw-r--r--FreeBSD/irc/catgirl/Makefile29
-rw-r--r--FreeBSD/irc/catgirl/distinfo3
-rw-r--r--FreeBSD/irc/catgirl/pkg-descr4
-rw-r--r--FreeBSD/irc/litterbox/Makefile32
-rw-r--r--FreeBSD/irc/litterbox/distinfo3
-rw-r--r--FreeBSD/irc/litterbox/pkg-descr4
-rw-r--r--FreeBSD/irc/pounce-notify/Makefile28
-rw-r--r--FreeBSD/irc/pounce-notify/distinfo3
-rw-r--r--FreeBSD/irc/pounce-notify/pkg-descr3
-rw-r--r--FreeBSD/irc/pounce-palaver/Makefile30
-rw-r--r--FreeBSD/irc/pounce-palaver/distinfo3
-rw-r--r--FreeBSD/irc/pounce-palaver/pkg-descr3
-rw-r--r--FreeBSD/irc/pounce/Makefile29
-rw-r--r--FreeBSD/irc/pounce/distinfo3
-rw-r--r--FreeBSD/irc/pounce/pkg-descr5
-rw-r--r--FreeBSD/irc/scooper/Makefile26
-rw-r--r--FreeBSD/irc/scooper/distinfo3
-rw-r--r--FreeBSD/irc/scooper/pkg-descr4
18 files changed, 215 insertions, 0 deletions
diff --git a/FreeBSD/irc/catgirl/Makefile b/FreeBSD/irc/catgirl/Makefile
new file mode 100644
index 0000000..48bf7e6
--- /dev/null
+++ b/FreeBSD/irc/catgirl/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	catgirl
+PORTVERSION=	1.9a
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/catgirl/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	TLS-only terminal IRC client
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+USES=		compiler:c++11-lang ncurses pkgconfig ssl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/catgirl \
+		man/man1/catgirl.1.gz
+
+.include <bsd.port.pre.mk>
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catgirl
+
+.if ${SSL_DEFAULT} == base || ${SSL_DEFAULT} == openssl
+LIB_DEPENDS+=	libtls.so:security/libretls
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/FreeBSD/irc/catgirl/distinfo b/FreeBSD/irc/catgirl/distinfo
new file mode 100644
index 0000000..55df704
--- /dev/null
+++ b/FreeBSD/irc/catgirl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630951196
+SHA256 (catgirl-1.9a.tar.gz) = 3049b99abad67cda7e9811c58c648e1afbdfbc127e1e8fcafa63d4c73243915d
+SIZE (catgirl-1.9a.tar.gz) = 62635
diff --git a/FreeBSD/irc/catgirl/pkg-descr b/FreeBSD/irc/catgirl/pkg-descr
new file mode 100644
index 0000000..8cae8df
--- /dev/null
+++ b/FreeBSD/irc/catgirl/pkg-descr
@@ -0,0 +1,4 @@
+catgirl is a TLS-only terminal IRC client with tab-complete, nick
+coloring, URL detection, message filtering and split scrolling.
+
+WWW: https://git.causal.agency/catgirl/
diff --git a/FreeBSD/irc/litterbox/Makefile b/FreeBSD/irc/litterbox/Makefile
new file mode 100644
index 0000000..d3b45e1
--- /dev/null
+++ b/FreeBSD/irc/litterbox/Makefile
@@ -0,0 +1,32 @@
+PORTNAME=	litterbox
+DISTVERSION=	1.8
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/litterbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Full-text search IRC logger
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/litterbox \
+		bin/scoop \
+		bin/unscoop \
+		man/man1/litterbox.1.gz \
+		man/man1/scoop.1.gz \
+		man/man1/unscoop.1.gz
+
+post-install:
+.for b in litterbox scoop unscoop
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/litterbox/distinfo b/FreeBSD/irc/litterbox/distinfo
new file mode 100644
index 0000000..f624af7
--- /dev/null
+++ b/FreeBSD/irc/litterbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622041216
+SHA256 (litterbox-1.8.tar.gz) = 54bebc3750f390813a3720eb0301ac4d852b30cb7b7605b178ed59aa51688552
+SIZE (litterbox-1.8.tar.gz) = 36827
diff --git a/FreeBSD/irc/litterbox/pkg-descr b/FreeBSD/irc/litterbox/pkg-descr
new file mode 100644
index 0000000..aed1c16
--- /dev/null
+++ b/FreeBSD/irc/litterbox/pkg-descr
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger with full-text search provided by
+SQLite3. It can be used as a logging bot or with the IRC bouncer pounce.
+
+WWW: https://git.causal.agency/litterbox/
diff --git a/FreeBSD/irc/pounce-notify/Makefile b/FreeBSD/irc/pounce-notify/Makefile
new file mode 100644
index 0000000..245b339
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Generic notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/notify
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-notify \
+		man/man1/pounce-notify.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-notify
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce-notify/distinfo b/FreeBSD/irc/pounce-notify/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce-notify/pkg-descr b/FreeBSD/irc/pounce-notify/pkg-descr
new file mode 100644
index 0000000..4b2437a
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/pkg-descr
@@ -0,0 +1,3 @@
+Generic notification provider for the pounce IRC bouncer.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/pounce-palaver/Makefile b/FreeBSD/irc/pounce-palaver/Makefile
new file mode 100644
index 0000000..df7534c
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/Makefile
@@ -0,0 +1,30 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Palaver push notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libcurl.so:ftp/curl \
+		libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/palaver
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-palaver \
+		man/man1/pounce-palaver.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-palaver
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce-palaver/distinfo b/FreeBSD/irc/pounce-palaver/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce-palaver/pkg-descr b/FreeBSD/irc/pounce-palaver/pkg-descr
new file mode 100644
index 0000000..77f9d96
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/pkg-descr
@@ -0,0 +1,3 @@
+Provider of Palaver push notifications for the pounce IRC bouncer.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/pounce/Makefile b/FreeBSD/irc/pounce/Makefile
new file mode 100644
index 0000000..92c806a
--- /dev/null
+++ b/FreeBSD/irc/pounce/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	pounce
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/calico \
+		bin/pounce \
+		man/man1/calico.1.gz \
+		man/man1/pounce.1.gz
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce/distinfo b/FreeBSD/irc/pounce/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce/pkg-descr b/FreeBSD/irc/pounce/pkg-descr
new file mode 100644
index 0000000..68679a2
--- /dev/null
+++ b/FreeBSD/irc/pounce/pkg-descr
@@ -0,0 +1,5 @@
+pounce is a multi-client, TLS-only IRC bouncer. It takes a simple
+approach, using a multiple-consumer ring buffer and the IRCv3.2
+server-time extension to communicate with clients.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/scooper/Makefile b/FreeBSD/irc/scooper/Makefile
new file mode 100644
index 0000000..1f9df37
--- /dev/null
+++ b/FreeBSD/irc/scooper/Makefile
@@ -0,0 +1,26 @@
+PORTNAME=	scooper
+DISTVERSION=	1.3
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/scooper/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Web interface for litterbox
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libkcgi.a:www/kcgi \
+		${LOCALBASE}/lib/libkcgihtml.a:www/kcgi
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/scooper \
+		man/man1/scooper.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scooper
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/scooper/distinfo b/FreeBSD/irc/scooper/distinfo
new file mode 100644
index 0000000..ca32657
--- /dev/null
+++ b/FreeBSD/irc/scooper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631565882
+SHA256 (scooper-1.3.tar.gz) = 8fa5dd6047290fba319dcd69d14e70e5efbe70cb5024224772fd5888cb457bfb
+SIZE (scooper-1.3.tar.gz) = 2324402
diff --git a/FreeBSD/irc/scooper/pkg-descr b/FreeBSD/irc/scooper/pkg-descr
new file mode 100644
index 0000000..830091a
--- /dev/null
+++ b/FreeBSD/irc/scooper/pkg-descr
@@ -0,0 +1,4 @@
+scooper is a CGI and FastCGI web interface for the litterbox IRC logger.
+It provides IRC log listings and full-text search.
+
+WWW: https://git.causal.agency/scooper/