summary refs log tree commit diff
path: root/FreeBSD
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
committerJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
commit97eb0074b135b2636d84ff503988e3d76803ddcc (patch)
treeb7bf84cab6a5df4035634f60e4b92ed8dbcf8c32 /FreeBSD
parentUpdate catsit to 1.4 (diff)
downloadports-97eb0074b135b2636d84ff503988e3d76803ddcc.tar.gz
ports-97eb0074b135b2636d84ff503988e3d76803ddcc.zip
Move FreeBSD ports under FreeBSD directory
Diffstat (limited to 'FreeBSD')
-rw-r--r--FreeBSD/Makefile22
-rw-r--r--FreeBSD/devel/cgit-causal-agency/Makefile71
-rw-r--r--FreeBSD/devel/cgit-causal-agency/distinfo5
-rw-r--r--FreeBSD/devel/cgit-causal-agency/files/pkg-message.in18
-rw-r--r--FreeBSD/devel/cgit-causal-agency/pkg-descr4
-rw-r--r--FreeBSD/devel/cgit-causal-agency/pkg-plist14
-rw-r--r--FreeBSD/irc/catgirl/Makefile29
-rw-r--r--FreeBSD/irc/catgirl/distinfo3
-rw-r--r--FreeBSD/irc/catgirl/pkg-descr4
-rw-r--r--FreeBSD/irc/litterbox/Makefile32
-rw-r--r--FreeBSD/irc/litterbox/distinfo3
-rw-r--r--FreeBSD/irc/litterbox/pkg-descr4
-rw-r--r--FreeBSD/irc/pounce-notify/Makefile28
-rw-r--r--FreeBSD/irc/pounce-notify/distinfo3
-rw-r--r--FreeBSD/irc/pounce-notify/pkg-descr3
-rw-r--r--FreeBSD/irc/pounce-palaver/Makefile30
-rw-r--r--FreeBSD/irc/pounce-palaver/distinfo3
-rw-r--r--FreeBSD/irc/pounce-palaver/pkg-descr3
-rw-r--r--FreeBSD/irc/pounce/Makefile29
-rw-r--r--FreeBSD/irc/pounce/distinfo3
-rw-r--r--FreeBSD/irc/pounce/pkg-descr5
-rw-r--r--FreeBSD/irc/scooper/Makefile26
-rw-r--r--FreeBSD/irc/scooper/distinfo3
-rw-r--r--FreeBSD/irc/scooper/pkg-descr4
-rw-r--r--FreeBSD/mail/bubger/Makefile27
-rw-r--r--FreeBSD/mail/bubger/distinfo3
-rw-r--r--FreeBSD/mail/bubger/pkg-descr6
-rw-r--r--FreeBSD/mail/imbox/Makefile27
-rw-r--r--FreeBSD/mail/imbox/distinfo3
-rw-r--r--FreeBSD/mail/imbox/pkg-descr5
-rw-r--r--FreeBSD/mail/notemap/Makefile27
-rw-r--r--FreeBSD/mail/notemap/distinfo3
-rw-r--r--FreeBSD/mail/notemap/pkg-descr4
-rw-r--r--FreeBSD/sysutils/catsit/Makefile28
-rw-r--r--FreeBSD/sysutils/catsit/distinfo3
-rw-r--r--FreeBSD/sysutils/catsit/pkg-descr5
36 files changed, 490 insertions, 0 deletions
diff --git a/FreeBSD/Makefile b/FreeBSD/Makefile
new file mode 100644
index 0000000..68bf9c4
--- /dev/null
+++ b/FreeBSD/Makefile
@@ -0,0 +1,22 @@
+PORTSDIR = /usr/ports
+
+PORTS += devel/cgit-causal-agency
+PORTS += irc/catgirl
+PORTS += irc/litterbox
+PORTS += irc/pounce
+PORTS += irc/pounce-palaver
+PORTS += irc/scooper
+PORTS += mail/bubger
+PORTS += mail/imbox
+PORTS += mail/notemap
+PORTS += sysutils/catsit
+
+install:
+.for PORT in ${PORTS}
+	cp -R ${PORT} ${PORTSDIR}/${PORT:H}
+.endfor
+
+uninstall:
+.for PORT in ${PORTS}
+	rm -fr ${PORTSDIR}/${PORT}
+.endfor
diff --git a/FreeBSD/devel/cgit-causal-agency/Makefile b/FreeBSD/devel/cgit-causal-agency/Makefile
new file mode 100644
index 0000000..be15f90
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/Makefile
@@ -0,0 +1,71 @@
+PORTNAME=	cgit-causal-agency
+PORTVERSION=	20210922
+CONFLICTS_INSTALL=	cgit
+CATEGORIES=	devel www
+MASTER_SITES=	https://git.causal.agency/src/snapshot/:src \
+		KERNEL_ORG/software/scm/git:git
+DISTFILES=	src-${SRC_VERSION}${EXTRACT_SUFX}:src \
+		git-${GIT_VERSION}${EXTRACT_SUFX}:git
+DISTNAME=	src-${SRC_VERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Fast, lightweight web frontend for Git repositories
+
+LICENSE=	GPLv2
+LICENSE_FILE=	${WRKSRC}/COPYING
+
+TEST_DEPENDS=	msgfmt:devel/gettext-tools
+
+SRC_VERSION=	5a8f6f3698fbd69b97483c7b84bf661f4761124f
+GIT_VERSION=	2.32.0
+WRKSRC_SUBDIR=	www/git.causal.agency/cgit
+
+USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
+CPE_VENDOR=	lars_hjemli
+USE_PERL5=	test
+SHEBANG_FILES=	filters/email-gravatar.py \
+		filters/html-converters/md2html \
+		filters/html-converters/rst2html \
+		filters/syntax-highlighting.py
+WWWDIR=	${PREFIX}/www/cgit
+
+CFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
+MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
+		prefix=${PREFIX} NO_GETTEXT=1 NO_R_TO_GCC_LINKER=1 V=1
+
+SUB_FILES=	pkg-message
+
+PORTDOCS=	cgitrc.5.txt
+
+OPTIONS_DEFINE=	DOCS ASCIIDOC
+OPTIONS_DEFAULT=	ASCIIDOC
+OPTIONS_SUB=	yes
+
+ASCIIDOC_DESC=	Use asciidoc to preprocess man page
+ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
+
+post-extract:
+	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
+
+post-patch:
+	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
+		${WRKSRC}/Makefile
+
+	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
+		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
+		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
+		${WRKSRC}/git/Makefile
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
+
+post-install-DOCS-on:
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-ASCIIDOC-on:
+	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
+	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/devel/cgit-causal-agency/distinfo b/FreeBSD/devel/cgit-causal-agency/distinfo
new file mode 100644
index 0000000..6397e05
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1632325421
+SHA256 (src-5a8f6f3698fbd69b97483c7b84bf661f4761124f.tar.gz) = f86404c02707dedbeba82bee3316b0c44a6d847b5c4a584bc5d0d20cc4528345
+SIZE (src-5a8f6f3698fbd69b97483c7b84bf661f4761124f.tar.gz) = 899773
+SHA256 (git-2.32.0.tar.gz) = 6038f06d396ba9dab2eee541c7db6e7f9f847f181ec62f3d8441893f8c469398
+SIZE (git-2.32.0.tar.gz) = 10321570
diff --git a/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in b/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in
new file mode 100644
index 0000000..0190639
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in
@@ -0,0 +1,18 @@
+[
+{ type: install
+  message: <<EOM
+cgit has been successfully installed.
+
+To enable cgit in Apache, use something like the following:
+
+  <Directory "%%WWWDIR%%/">
+      AllowOverride None
+      Options +ExecCGI
+      Require all granted 
+  </Directory>
+
+Documentation and sample configuration can be found
+in %%DOCSDIR%%/cgitrc.5.txt.
+EOM
+}
+]
diff --git a/FreeBSD/devel/cgit-causal-agency/pkg-descr b/FreeBSD/devel/cgit-causal-agency/pkg-descr
new file mode 100644
index 0000000..1a9d828
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/pkg-descr
@@ -0,0 +1,4 @@
+cgit is a fast web interface for the Git SCM, using a built-in cache to
+decrease server I/O pressure.
+
+WWW: https://git.zx2c4.com/cgit/about/
diff --git a/FreeBSD/devel/cgit-causal-agency/pkg-plist b/FreeBSD/devel/cgit-causal-agency/pkg-plist
new file mode 100644
index 0000000..ad44adb
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/pkg-plist
@@ -0,0 +1,14 @@
+lib/cgit/filters/about-formatting.sh
+lib/cgit/filters/commit-links.sh
+lib/cgit/filters/email-gravatar.py
+lib/cgit/filters/html-converters/man2html
+lib/cgit/filters/html-converters/md2html
+lib/cgit/filters/html-converters/rst2html
+lib/cgit/filters/html-converters/txt2html
+lib/cgit/filters/syntax-highlighting.py
+lib/cgit/filters/syntax-highlighting.sh
+%%ASCIIDOC%%man/man5/cgitrc.5.gz
+%%WWWDIR%%/cgit.cgi
+%%WWWDIR%%/cgit.css
+%%WWWDIR%%/cgit.png
+%%WWWDIR%%/robots.txt
diff --git a/FreeBSD/irc/catgirl/Makefile b/FreeBSD/irc/catgirl/Makefile
new file mode 100644
index 0000000..48bf7e6
--- /dev/null
+++ b/FreeBSD/irc/catgirl/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	catgirl
+PORTVERSION=	1.9a
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/catgirl/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	TLS-only terminal IRC client
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+USES=		compiler:c++11-lang ncurses pkgconfig ssl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/catgirl \
+		man/man1/catgirl.1.gz
+
+.include <bsd.port.pre.mk>
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catgirl
+
+.if ${SSL_DEFAULT} == base || ${SSL_DEFAULT} == openssl
+LIB_DEPENDS+=	libtls.so:security/libretls
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/FreeBSD/irc/catgirl/distinfo b/FreeBSD/irc/catgirl/distinfo
new file mode 100644
index 0000000..55df704
--- /dev/null
+++ b/FreeBSD/irc/catgirl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630951196
+SHA256 (catgirl-1.9a.tar.gz) = 3049b99abad67cda7e9811c58c648e1afbdfbc127e1e8fcafa63d4c73243915d
+SIZE (catgirl-1.9a.tar.gz) = 62635
diff --git a/FreeBSD/irc/catgirl/pkg-descr b/FreeBSD/irc/catgirl/pkg-descr
new file mode 100644
index 0000000..8cae8df
--- /dev/null
+++ b/FreeBSD/irc/catgirl/pkg-descr
@@ -0,0 +1,4 @@
+catgirl is a TLS-only terminal IRC client with tab-complete, nick
+coloring, URL detection, message filtering and split scrolling.
+
+WWW: https://git.causal.agency/catgirl/
diff --git a/FreeBSD/irc/litterbox/Makefile b/FreeBSD/irc/litterbox/Makefile
new file mode 100644
index 0000000..d3b45e1
--- /dev/null
+++ b/FreeBSD/irc/litterbox/Makefile
@@ -0,0 +1,32 @@
+PORTNAME=	litterbox
+DISTVERSION=	1.8
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/litterbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Full-text search IRC logger
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/litterbox \
+		bin/scoop \
+		bin/unscoop \
+		man/man1/litterbox.1.gz \
+		man/man1/scoop.1.gz \
+		man/man1/unscoop.1.gz
+
+post-install:
+.for b in litterbox scoop unscoop
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/litterbox/distinfo b/FreeBSD/irc/litterbox/distinfo
new file mode 100644
index 0000000..f624af7
--- /dev/null
+++ b/FreeBSD/irc/litterbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622041216
+SHA256 (litterbox-1.8.tar.gz) = 54bebc3750f390813a3720eb0301ac4d852b30cb7b7605b178ed59aa51688552
+SIZE (litterbox-1.8.tar.gz) = 36827
diff --git a/FreeBSD/irc/litterbox/pkg-descr b/FreeBSD/irc/litterbox/pkg-descr
new file mode 100644
index 0000000..aed1c16
--- /dev/null
+++ b/FreeBSD/irc/litterbox/pkg-descr
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger with full-text search provided by
+SQLite3. It can be used as a logging bot or with the IRC bouncer pounce.
+
+WWW: https://git.causal.agency/litterbox/
diff --git a/FreeBSD/irc/pounce-notify/Makefile b/FreeBSD/irc/pounce-notify/Makefile
new file mode 100644
index 0000000..245b339
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Generic notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/notify
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-notify \
+		man/man1/pounce-notify.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-notify
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce-notify/distinfo b/FreeBSD/irc/pounce-notify/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce-notify/pkg-descr b/FreeBSD/irc/pounce-notify/pkg-descr
new file mode 100644
index 0000000..4b2437a
--- /dev/null
+++ b/FreeBSD/irc/pounce-notify/pkg-descr
@@ -0,0 +1,3 @@
+Generic notification provider for the pounce IRC bouncer.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/pounce-palaver/Makefile b/FreeBSD/irc/pounce-palaver/Makefile
new file mode 100644
index 0000000..df7534c
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/Makefile
@@ -0,0 +1,30 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Palaver push notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libcurl.so:ftp/curl \
+		libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/palaver
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-palaver \
+		man/man1/pounce-palaver.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-palaver
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce-palaver/distinfo b/FreeBSD/irc/pounce-palaver/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce-palaver/pkg-descr b/FreeBSD/irc/pounce-palaver/pkg-descr
new file mode 100644
index 0000000..77f9d96
--- /dev/null
+++ b/FreeBSD/irc/pounce-palaver/pkg-descr
@@ -0,0 +1,3 @@
+Provider of Palaver push notifications for the pounce IRC bouncer.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/pounce/Makefile b/FreeBSD/irc/pounce/Makefile
new file mode 100644
index 0000000..92c806a
--- /dev/null
+++ b/FreeBSD/irc/pounce/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	pounce
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/calico \
+		bin/pounce \
+		man/man1/calico.1.gz \
+		man/man1/pounce.1.gz
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce/distinfo b/FreeBSD/irc/pounce/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce/pkg-descr b/FreeBSD/irc/pounce/pkg-descr
new file mode 100644
index 0000000..68679a2
--- /dev/null
+++ b/FreeBSD/irc/pounce/pkg-descr
@@ -0,0 +1,5 @@
+pounce is a multi-client, TLS-only IRC bouncer. It takes a simple
+approach, using a multiple-consumer ring buffer and the IRCv3.2
+server-time extension to communicate with clients.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/FreeBSD/irc/scooper/Makefile b/FreeBSD/irc/scooper/Makefile
new file mode 100644
index 0000000..1f9df37
--- /dev/null
+++ b/FreeBSD/irc/scooper/Makefile
@@ -0,0 +1,26 @@
+PORTNAME=	scooper
+DISTVERSION=	1.3
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/scooper/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Web interface for litterbox
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libkcgi.a:www/kcgi \
+		${LOCALBASE}/lib/libkcgihtml.a:www/kcgi
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/scooper \
+		man/man1/scooper.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scooper
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/scooper/distinfo b/FreeBSD/irc/scooper/distinfo
new file mode 100644
index 0000000..ca32657
--- /dev/null
+++ b/FreeBSD/irc/scooper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631565882
+SHA256 (scooper-1.3.tar.gz) = 8fa5dd6047290fba319dcd69d14e70e5efbe70cb5024224772fd5888cb457bfb
+SIZE (scooper-1.3.tar.gz) = 2324402
diff --git a/FreeBSD/irc/scooper/pkg-descr b/FreeBSD/irc/scooper/pkg-descr
new file mode 100644
index 0000000..830091a
--- /dev/null
+++ b/FreeBSD/irc/scooper/pkg-descr
@@ -0,0 +1,4 @@
+scooper is a CGI and FastCGI web interface for the litterbox IRC logger.
+It provides IRC log listings and full-text search.
+
+WWW: https://git.causal.agency/scooper/
diff --git a/FreeBSD/mail/bubger/Makefile b/FreeBSD/mail/bubger/Makefile
new file mode 100644
index 0000000..9f6d98f
--- /dev/null
+++ b/FreeBSD/mail/bubger/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	bubger
+DISTVERSION=	1.1
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/bubger/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP archive generator
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	iconv pkgconfig
+CFLAGS+=	-I${ICONV_PREFIX}/include
+LDFLAGS+=	-L${ICONV_PREFIX}/lib ${ICONV_LIB}
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/bubger \
+		man/man1/bubger.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/bubger
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/bubger/distinfo b/FreeBSD/mail/bubger/distinfo
new file mode 100644
index 0000000..77fb94f
--- /dev/null
+++ b/FreeBSD/mail/bubger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623954809
+SHA256 (bubger-1.1.tar.gz) = 867b7c055a2e81384e9bcdcd12ecf38c0e78891e9768b697875547e0ce4d9904
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/FreeBSD/mail/bubger/pkg-descr b/FreeBSD/mail/bubger/pkg-descr
new file mode 100644
index 0000000..1532b98
--- /dev/null
+++ b/FreeBSD/mail/bubger/pkg-descr
@@ -0,0 +1,6 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access. It requires the IMAP
+THREAD extension.
+
+WWW: https://git.causal.agency/bubger/
diff --git a/FreeBSD/mail/imbox/Makefile b/FreeBSD/mail/imbox/Makefile
new file mode 100644
index 0000000..5f83e69
--- /dev/null
+++ b/FreeBSD/mail/imbox/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	imbox
+DISTVERSION=	1.4
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/imbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP to mbox
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-fetch-email \
+		bin/imbox \
+		man/man1/git-fetch-email.1.gz \
+		man/man1/imbox.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/imbox
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/imbox/distinfo b/FreeBSD/mail/imbox/distinfo
new file mode 100644
index 0000000..e7afbd3
--- /dev/null
+++ b/FreeBSD/mail/imbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615244342
+SHA256 (imbox-1.4.tar.gz) = 0a264f58f7306d8481a559220cc20a0673a425581d4805b3f7a02dcb61fc9b3a
+SIZE (imbox-1.4.tar.gz) = 23083
diff --git a/FreeBSD/mail/imbox/pkg-descr b/FreeBSD/mail/imbox/pkg-descr
new file mode 100644
index 0000000..76aa3e6
--- /dev/null
+++ b/FreeBSD/mail/imbox/pkg-descr
@@ -0,0 +1,5 @@
+imbox is a small TLS-only IMAP client intended for applying git patches
+without need of any other mail client. It includes git-fetch-email, a
+wrapper modeled after git-send-email.
+
+WWW: https://git.causal.agency/imbox/
diff --git a/FreeBSD/mail/notemap/Makefile b/FreeBSD/mail/notemap/Makefile
new file mode 100644
index 0000000..d5220b3
--- /dev/null
+++ b/FreeBSD/mail/notemap/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	notemap
+DISTVERSION=	1.3
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/notemap/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	mirror notes to IMAP
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-notemap \
+		bin/notemap \
+		man/man1/git-notemap.1.gz \
+		man/man1/notemap.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notemap
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/notemap/distinfo b/FreeBSD/mail/notemap/distinfo
new file mode 100644
index 0000000..135e1c3
--- /dev/null
+++ b/FreeBSD/mail/notemap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608333183
+SHA256 (notemap-1.3.tar.gz) = 76f9f44963546d443420f03159d6bebfd4d661a67dd8e4e59ccde5d23f51c68d
+SIZE (notemap-1.3.tar.gz) = 22773
diff --git a/FreeBSD/mail/notemap/pkg-descr b/FreeBSD/mail/notemap/pkg-descr
new file mode 100644
index 0000000..67622a8
--- /dev/null
+++ b/FreeBSD/mail/notemap/pkg-descr
@@ -0,0 +1,4 @@
+notemap mirrors text files to an IMAP mailbox in a format compatible
+with the iOS Notes app.
+
+WWW: https://git.causal.agency/notemap/
diff --git a/FreeBSD/sysutils/catsit/Makefile b/FreeBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..c65563f
--- /dev/null
+++ b/FreeBSD/sysutils/catsit/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	catsit
+DISTVERSION=	1.4
+CATEGORIES=	sysutils
+MASTER_SITES=	https://git.causal.agency/catsit/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Process supervisor
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+PLIST_FILES=	bin/catsit-timer \
+		bin/catsit-watch \
+		etc/rc.d/catsitd \
+		man/man1/catsit-timer.1.gz \
+		man/man1/catsit-watch.1.gz \
+		man/man5/catsit.conf.5.gz \
+		man/man8/catsit.8.gz \
+		man/man8/catsitd.8.gz \
+		sbin/catsit \
+		sbin/catsitd
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catsit-timer
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catsit-watch
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/catsitd
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/sysutils/catsit/distinfo b/FreeBSD/sysutils/catsit/distinfo
new file mode 100644
index 0000000..964fc35
--- /dev/null
+++ b/FreeBSD/sysutils/catsit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632937248
+SHA256 (catsit-1.4.tar.gz) = 8326ef2e9312092cdf121c6ba3df7b93f8228fca5b514e6b05b98c848535e4d8
+SIZE (catsit-1.4.tar.gz) = 24341
diff --git a/FreeBSD/sysutils/catsit/pkg-descr b/FreeBSD/sysutils/catsit/pkg-descr
new file mode 100644
index 0000000..132a488
--- /dev/null
+++ b/FreeBSD/sysutils/catsit/pkg-descr
@@ -0,0 +1,5 @@
+catsit is a process supervisor for processes which run in the
+foreground, log to standard output or standard error, handle errors by
+exiting and expect to be restarted.
+
+WWW: https://git.causal.agency/catsit/