summary refs log tree commit diff
path: root/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-07 18:10:50 +0000
committerJune McEnroe <june@causal.agency>2020-08-07 18:10:50 +0000
commit0991bf3de8bf15521a636f4df70e94fb1389040a (patch)
treebcaa6a1878720e2f70b294f1eb38cdddb361aabb /Makefile
parentUpdate pounce to 1.4 (diff)
downloadports-0991bf3de8bf15521a636f4df70e94fb1389040a.tar.gz
ports-0991bf3de8bf15521a636f4df70e94fb1389040a.zip
Add Makefile to copy ports into /usr/ports
It's so nice to be able to use FreeBSD make(1) features...
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..9cd00db
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+PORTSDIR = /usr/ports
+
+PORTS += devel/cgit-patched
+PORTS += irc/catgirl
+PORTS += irc/pounce
+PORTS += security/libretls
+
+install:
+.for PORT in ${PORTS}
+	cp -R ${PORT} ${PORTSDIR}/${PORT:H}
+.endfor
+
+uninstall:
+.for PORT in ${PORTS}
+	rm -fr ${PORTSDIR}/${PORT}
+.endfor