summary refs log tree commit diff
path: root/OpenBSD/net/bubger/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2023-07-10 16:11:22 -0400
committerJune McEnroe <june@causal.agency>2023-07-10 16:11:22 -0400
commit1d519a192858ba47a3b5062916c1b22c7b6f55ee (patch)
tree38c2952e460c859a1ef56724b7f85fc82db80bd2 /OpenBSD/net/bubger/Makefile
parentFreeBSD: Update litterbox to 1.9 (diff)
downloadports-1d519a192858ba47a3b5062916c1b22c7b6f55ee.tar.gz
ports-1d519a192858ba47a3b5062916c1b22c7b6f55ee.zip
OpenBSD: Add net/bubger
Diffstat (limited to 'OpenBSD/net/bubger/Makefile')
-rw-r--r--OpenBSD/net/bubger/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/OpenBSD/net/bubger/Makefile b/OpenBSD/net/bubger/Makefile
new file mode 100644
index 0000000..d226626
--- /dev/null
+++ b/OpenBSD/net/bubger/Makefile
@@ -0,0 +1,30 @@
+COMMENT =	IMAP archive generator
+
+DISTNAME =	bubger-1.1
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/bubger/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+LIB_DEPENDS =	converters/libiconv
+
+MASTER_SITES =		https://git.causal.agency/bubger/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>