summary refs log tree commit diff
path: root/irc/litterbox/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-10 16:29:01 +0000
committerJune McEnroe <june@causal.agency>2020-08-10 16:29:01 +0000
commit4cd92f7de83f8992cfd210d4d1dffca620089a45 (patch)
tree741c1cba7b270e306a2132a23701762bd5f8d7c6 /irc/litterbox/Makefile
parentAdd missing USES=pkgconfig to pounce (diff)
downloadports-4cd92f7de83f8992cfd210d4d1dffca620089a45.tar.gz
ports-4cd92f7de83f8992cfd210d4d1dffca620089a45.zip
Add litterbox port
Diffstat (limited to 'irc/litterbox/Makefile')
-rw-r--r--irc/litterbox/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/irc/litterbox/Makefile b/irc/litterbox/Makefile
new file mode 100644
index 0000000..d41308a
--- /dev/null
+++ b/irc/litterbox/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME=	litterbox
+DISTVERSION=	1.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/litterbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Full-text search IRC logger
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/litterbox \
+		bin/scoop \
+		bin/unscoop \
+		etc/rc.d/litterbox \
+		man/man1/litterbox.1.gz \
+		man/man1/scoop.1.gz \
+		man/man1/unscoop.1.gz
+
+post-install:
+.for b in litterbox scoop unscoop
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>