summary refs log tree commit diff
path: root/irc/scooper/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-23 19:28:45 +0000
committerJune McEnroe <june@causal.agency>2020-08-23 19:28:45 +0000
commit89e3ffdeded210fd49f19f93af2f73d58f523b5d (patch)
tree89514e343579533c0100240ceea6e639de392d22 /irc/scooper/Makefile
parentAdd catsit port (diff)
downloadports-89e3ffdeded210fd49f19f93af2f73d58f523b5d.tar.gz
ports-89e3ffdeded210fd49f19f93af2f73d58f523b5d.zip
Add scooper port
Diffstat (limited to 'irc/scooper/Makefile')
-rw-r--r--irc/scooper/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/irc/scooper/Makefile b/irc/scooper/Makefile
new file mode 100644
index 0000000..f53c714
--- /dev/null
+++ b/irc/scooper/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	scooper
+DISTVERSION=	1.0
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/scooper/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Web interface for litterbox
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libkcgi.a:www/kcgi \
+		${LOCALBASE}/lib/libkcgihtml.a:www/kcgi \
+		${LOCALBASE}/lib/libsqlite3.a:databases/sqlite3
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/scooper \
+		man/man1/scooper.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scooper
+
+.include <bsd.port.mk>