summary refs log tree commit diff
path: root/security/libretls/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 20:09:34 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 20:09:34 +0000
commite3c5c188010d9bb117869cd8bda6efbb7f6d1ddb (patch)
treeeb1550772dcd7257cd13c92bcaf380db2fcb70dc /security/libretls/Makefile
parentAdd cgit-patched port (diff)
downloadports-e3c5c188010d9bb117869cd8bda6efbb7f6d1ddb.tar.gz
ports-e3c5c188010d9bb117869cd8bda6efbb7f6d1ddb.zip
Add libretls port
Based on libressl port.
Diffstat (limited to 'security/libretls/Makefile')
-rw-r--r--security/libretls/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
new file mode 100644
index 0000000..4d4a83a
--- /dev/null
+++ b/security/libretls/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME=	libretls
+PORTVERSION=	3.2.0
+CATEGORIES=	security devel
+MASTER_SITES=	https://causal.agency/libretls/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Port of libtls for OpenSSL
+
+LICENSE=	ISCL
+
+BROKEN_SSL=			libressl
+BROKEN_SSL_REASON_libressl=	libtls is provided by LibreSSL
+
+USES=		libtool pathfix pkgconfig ssl
+USE_LDCONFIG=	yes
+GNU_CONFIGURE=	yes
+CONFIGURE_ARGS+=	--with-openssl=${OPENSSLBASE}
+CFLAGS+=	-fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
+LDFLAGS+=	-pthread
+
+CONFLICTS_INSTALL=	libressl-[0-9]* \
+			libressl-devel-[0-9]*
+
+INSTALL_TARGET=		install-strip
+
+.include <bsd.port.mk>