summary refs log tree commit diff
path: root/sysutils/catsit/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-23 17:08:07 +0000
committerJune McEnroe <june@causal.agency>2020-08-23 17:08:07 +0000
commit67588c96b31acbe6ceef773a856c8a3d281fa532 (patch)
tree3d8c3901ae2a094dd19e7dd3c366ae893f962042 /sysutils/catsit/Makefile
parentUpdate pounce to 1.4p2 (diff)
downloadports-67588c96b31acbe6ceef773a856c8a3d281fa532.tar.gz
ports-67588c96b31acbe6ceef773a856c8a3d281fa532.zip
Add catsit port
Diffstat (limited to 'sysutils/catsit/Makefile')
-rw-r--r--sysutils/catsit/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/catsit/Makefile b/sysutils/catsit/Makefile
new file mode 100644
index 0000000..6eae43f
--- /dev/null
+++ b/sysutils/catsit/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME=	catsit
+DISTVERSION=	1.0
+CATEGORIES=	sysutils
+MASTER_SITES=	https://git.causal.agency/catsit/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Process supervisor
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+PLIST_FILES=	etc/rc.d/catsitd \
+		man/man5/catsit.conf.5.gz \
+		man/man8/catsit.8.gz \
+		man/man8/catsitd.8.gz \
+		sbin/catsit \
+		sbin/catsitd
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/catsitd
+
+.include <bsd.port.mk>