summary refs log tree commit diff
path: root/sysutils/catsit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/catsit/Makefile')
-rw-r--r--sysutils/catsit/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/catsit/Makefile b/sysutils/catsit/Makefile
new file mode 100644
index 0000000..6eae43f
--- /dev/null
+++ b/sysutils/catsit/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME=	catsit
+DISTVERSION=	1.0
+CATEGORIES=	sysutils
+MASTER_SITES=	https://git.causal.agency/catsit/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Process supervisor
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+PLIST_FILES=	etc/rc.d/catsitd \
+		man/man5/catsit.conf.5.gz \
+		man/man8/catsit.8.gz \
+		man/man8/catsitd.8.gz \
+		sbin/catsit \
+		sbin/catsitd
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/catsitd
+
+.include <bsd.port.mk>