summary refs log tree commit diff
path: root/OpenBSD/net/pounce-notify/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2022-04-05 23:00:02 +0000
committerJune McEnroe <june@causal.agency>2022-04-05 23:10:41 +0000
commiteee90a1635b2463527e0448d8dd0dc8410411b5a (patch)
treeee234190a748787ecd4a0649823a208436bd92d3 /OpenBSD/net/pounce-notify/Makefile
parentOpenBSD: sync pounce port with upstream (diff)
downloadports-eee90a1635b2463527e0448d8dd0dc8410411b5a.tar.gz
ports-eee90a1635b2463527e0448d8dd0dc8410411b5a.zip
OpenBSD: Add pounce-notify port
Diffstat (limited to 'OpenBSD/net/pounce-notify/Makefile')
-rw-r--r--OpenBSD/net/pounce-notify/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce-notify/Makefile b/OpenBSD/net/pounce-notify/Makefile
new file mode 100644
index 0000000..f472957
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/Makefile
@@ -0,0 +1,33 @@
+COMMENT =	notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-notify-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/notify
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>