summary refs log tree commit diff
path: root/OpenBSD/net/pounce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net/pounce/Makefile')
-rw-r--r--OpenBSD/net/pounce/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..892a415
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,26 @@
+# $OpenBSD$
+
+COMMENT =	IRC bouncer
+DISTNAME =	pounce-2.5
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+MAKE_FLAGS +=	LDADD.crypt=
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>