summary refs log tree commit diff
path: root/OpenBSD/net/pounce/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-10-02 01:51:29 +0000
committerJune McEnroe <june@causal.agency>2021-10-02 01:51:29 +0000
commitad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61 (patch)
treea74d810f757975c4aab93dbe4cde18d9c1afd81d /OpenBSD/net/pounce/Makefile
parentOpenBSD: Add port for catsit (diff)
downloadports-ad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61.tar.gz
ports-ad2447402d7a90d6bff6fb2f3e2fdbcf77c66a61.zip
OpenBSD: Add port for pounce
Diffstat (limited to 'OpenBSD/net/pounce/Makefile')
-rw-r--r--OpenBSD/net/pounce/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..892a415
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,26 @@
+# $OpenBSD$
+
+COMMENT =	IRC bouncer
+DISTNAME =	pounce-2.5
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c tls
+
+MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+MAKE_FLAGS +=	LDADD.crypt=
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>