summary refs log tree commit diff
path: root/OpenBSD/sysutils/catsit/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-10-02 01:43:16 +0000
committerJune McEnroe <june@causal.agency>2021-10-02 01:43:16 +0000
commit8700de424e03b4fabc6a96b7cd235bae4d316310 (patch)
tree9536d5cf49204d70094a9b9f23b149898b36b548 /OpenBSD/sysutils/catsit/Makefile
parentOpenBSD: Build and install git{,-http-backend} with cgit (diff)
downloadports-8700de424e03b4fabc6a96b7cd235bae4d316310.tar.gz
ports-8700de424e03b4fabc6a96b7cd235bae4d316310.zip
OpenBSD: Add port for catsit
Diffstat (limited to 'OpenBSD/sysutils/catsit/Makefile')
-rw-r--r--OpenBSD/sysutils/catsit/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/OpenBSD/sysutils/catsit/Makefile b/OpenBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..a26f6a8
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/Makefile
@@ -0,0 +1,25 @@
+# $OpenBSD$
+
+COMMENT =	process supervisor
+DISTNAME =	catsit-1.4
+CATEGORIES =	sysutils
+HOMEPAGE =	https://git.causal.agency/catsit/about/
+MAINTAINER =		june@causal.agency
+
+# AGPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c
+
+MASTER_SITES =		https://git.causal.agency/catsit/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>