summary refs log tree commit diff
path: root/OpenBSD/www/cgit-pink/patches
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/www/cgit-pink/patches')
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-Makefile30
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-cgit_mk11
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-setup_c20
3 files changed, 61 insertions, 0 deletions
diff --git a/OpenBSD/www/cgit-pink/patches/patch-Makefile b/OpenBSD/www/cgit-pink/patches/patch-Makefile
new file mode 100644
index 0000000..b49eb37
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-Makefile
@@ -0,0 +1,30 @@
+$OpenBSD: patch-Makefile,v 1.9 2018/08/04 09:19:35 kn Exp $
+Index: Makefile
+--- Makefile.orig
++++ Makefile
+@@ -2,11 +2,11 @@ all::
+ 
+ CGIT_VERSION = v1.2.1
+ CGIT_SCRIPT_NAME = cgit.cgi
+-CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
+-CGIT_DATA_PATH = $(CGIT_SCRIPT_PATH)
+-CGIT_CONFIG = /etc/cgitrc
+-CACHE_ROOT = /var/cache/cgit
+-prefix = /usr/local
++CGIT_SCRIPT_PATH = /var/www/cgi-bin
++CGIT_DATA_PATH = /var/www/htdocs
++CGIT_CONFIG = /conf/cgitrc
++CACHE_ROOT = /tmp/cgit
++prefix = ${PREFIX}
+ libdir = $(prefix)/lib
+ filterdir = $(libdir)/cgit/filters
+ docdir = $(prefix)/share/doc/cgit
+@@ -90,8 +90,6 @@ install: all
+ 	$(INSTALL) -m 0644 cgit.png $(DESTDIR)$(CGIT_DATA_PATH)/cgit.png
+ 	$(INSTALL) -m 0644 favicon.ico $(DESTDIR)$(CGIT_DATA_PATH)/favicon.ico
+ 	$(INSTALL) -m 0644 robots.txt $(DESTDIR)$(CGIT_DATA_PATH)/robots.txt
+-	$(INSTALL) -m 0755 -d $(DESTDIR)$(filterdir)
+-	$(COPYTREE) filters/* $(DESTDIR)$(filterdir)
+ 
+ install-doc: install-man install-html install-pdf
+ 
diff --git a/OpenBSD/www/cgit-pink/patches/patch-cgit_mk b/OpenBSD/www/cgit-pink/patches/patch-cgit_mk
new file mode 100644
index 0000000..c74f62d
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-cgit_mk
@@ -0,0 +1,11 @@
+$OpenBSD: patch-cgit_mk,v 1.1 2013/07/15 07:00:49 jasper Exp $
+--- cgit.mk.orig	Sun Jul 14 23:18:05 2013
++++ cgit.mk	Sun Jul 14 23:18:39 2013
+@@ -17,6 +17,7 @@ $(CGIT_PREFIX)VERSION: force-version
+ 
+ # CGIT_CFLAGS is a separate variable so that we can track it separately
+ # and avoid rebuilding all of Git when these variables change.
++CGIT_CFLAGS += -L${LOCALBASE}/include
+ CGIT_CFLAGS += -DCGIT_CONFIG='"$(CGIT_CONFIG)"'
+ CGIT_CFLAGS += -DCGIT_SCRIPT_NAME='"$(CGIT_SCRIPT_NAME)"'
+ CGIT_CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
diff --git a/OpenBSD/www/cgit-pink/patches/patch-setup_c b/OpenBSD/www/cgit-pink/patches/patch-setup_c
new file mode 100644
index 0000000..eae3fc0
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-setup_c
@@ -0,0 +1,20 @@
+$OpenBSD: patch-setup_c,v 1.1 2017/03/22 20:23:52 landry Exp $
+
+Dont openbsd dev/null, doesnt exist in the default chroot
+
+--- git/setup.c.orig	Wed Mar  1 21:01:06 2017
++++ git/setup.c	Wed Mar  1 21:01:56 2017
+@@ -1488,11 +1488,13 @@ const char *resolve_gitdir_gently(const char *suspect, int *return_error_code)
+ /* if any standard file descriptor is missing open it to /dev/null */
+ void sanitize_stdfds(void)
+ {
++#if 0
+ 	int fd = xopen("/dev/null", O_RDWR);
+ 	while (fd < 2)
+ 		fd = xdup(fd);
+ 	if (fd > 2)
+ 		close(fd);
++#endif
+ }
+ 
+ int daemonize(void)