summary refs log tree commit diff
path: root/OpenBSD
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD')
-rw-r--r--OpenBSD/net/bubger/Makefile30
-rw-r--r--OpenBSD/net/bubger/distinfo2
-rw-r--r--OpenBSD/net/bubger/pkg/DESCR4
-rw-r--r--OpenBSD/net/bubger/pkg/PLIST3
-rw-r--r--OpenBSD/net/litterbox/Makefile27
-rw-r--r--OpenBSD/net/litterbox/distinfo2
-rw-r--r--OpenBSD/net/litterbox/pkg/DESCR4
-rw-r--r--OpenBSD/net/litterbox/pkg/PLIST7
-rw-r--r--OpenBSD/net/pounce-notify/Makefile33
-rw-r--r--OpenBSD/net/pounce-notify/distinfo2
-rw-r--r--OpenBSD/net/pounce-notify/pkg/DESCR1
-rw-r--r--OpenBSD/net/pounce-notify/pkg/PLIST2
-rw-r--r--OpenBSD/net/pounce-palaver/Makefile35
-rw-r--r--OpenBSD/net/pounce-palaver/distinfo2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/DESCR2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/PLIST2
-rw-r--r--OpenBSD/net/pounce/Makefile29
-rw-r--r--OpenBSD/net/pounce/distinfo2
-rw-r--r--OpenBSD/net/pounce/pkg/DESCR7
-rw-r--r--OpenBSD/net/pounce/pkg/PLIST4
-rw-r--r--OpenBSD/sysutils/catsit/Makefile25
-rw-r--r--OpenBSD/sysutils/catsit/distinfo2
-rw-r--r--OpenBSD/sysutils/catsit/pkg/DESCR5
-rw-r--r--OpenBSD/sysutils/catsit/pkg/PLIST11
-rw-r--r--OpenBSD/www/cgit-pink/Makefile39
-rw-r--r--OpenBSD/www/cgit-pink/distinfo4
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-Makefile30
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-cgit_mk11
-rw-r--r--OpenBSD/www/cgit-pink/patches/patch-setup_c20
-rw-r--r--OpenBSD/www/cgit-pink/pkg/DESCR2
-rw-r--r--OpenBSD/www/cgit-pink/pkg/PLIST14
-rw-r--r--OpenBSD/www/cgit-pink/pkg/README74
32 files changed, 437 insertions, 0 deletions
diff --git a/OpenBSD/net/bubger/Makefile b/OpenBSD/net/bubger/Makefile
new file mode 100644
index 0000000..69a8e74
--- /dev/null
+++ b/OpenBSD/net/bubger/Makefile
@@ -0,0 +1,30 @@
+COMMENT =	IMAP archive generator
+
+DISTNAME =	bubger-1.1
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/bubger/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+LIB_DEPENDS =	converters/libiconv
+
+SITES =		https://git.causal.agency/bubger/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/bubger/distinfo b/OpenBSD/net/bubger/distinfo
new file mode 100644
index 0000000..fb1a071
--- /dev/null
+++ b/OpenBSD/net/bubger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bubger-1.1.tar.gz) = hnt8BVougThOm83NEuzzjA54iR6XaLaXh1VH4M5NmQQ=
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/OpenBSD/net/bubger/pkg/DESCR b/OpenBSD/net/bubger/pkg/DESCR
new file mode 100644
index 0000000..fb62e9f
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/DESCR
@@ -0,0 +1,4 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access.  It requires the
+IMAP THREAD extension.
diff --git a/OpenBSD/net/bubger/pkg/PLIST b/OpenBSD/net/bubger/pkg/PLIST
new file mode 100644
index 0000000..2803d1c
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/PLIST
@@ -0,0 +1,3 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/bubger
+@man man/man1/bubger.1
diff --git a/OpenBSD/net/litterbox/Makefile b/OpenBSD/net/litterbox/Makefile
new file mode 100644
index 0000000..6a9f64a
--- /dev/null
+++ b/OpenBSD/net/litterbox/Makefile
@@ -0,0 +1,27 @@
+# $OpenBSD$
+
+COMMENT =	IRC logger
+DISTNAME =	litterbox-1.8
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/litterbox/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+WANTLIB =		c sqlite3 tls
+LIB_DEPENDS =	databases/sqlite3
+
+SITES =		https://git.causal.agency/litterbox/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+CFLAGS +=	-I${LOCALBASE}/include
+MAKE_FLAGS +=	LDFLAGS=-L${LOCALBASE}/lib
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/litterbox/distinfo b/OpenBSD/net/litterbox/distinfo
new file mode 100644
index 0000000..d8a3759
--- /dev/null
+++ b/OpenBSD/net/litterbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (litterbox-1.8.tar.gz) = VL68N1DzkIE6NyDrAwGsTYUrMMt7dgWxeO1ZqlFohVI=
+SIZE (litterbox-1.8.tar.gz) = 36827
diff --git a/OpenBSD/net/litterbox/pkg/DESCR b/OpenBSD/net/litterbox/pkg/DESCR
new file mode 100644
index 0000000..c50791d
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/DESCR
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger.  It logs events from IRC in a
+SQLite database, indexing messages for full-text search.  It is
+intended for use with the IRC bouncer pounce, but can also be used
+independently as a logging bot.
diff --git a/OpenBSD/net/litterbox/pkg/PLIST b/OpenBSD/net/litterbox/pkg/PLIST
new file mode 100644
index 0000000..606da42
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/PLIST
@@ -0,0 +1,7 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/litterbox
+@bin bin/scoop
+@bin bin/unscoop
+@man man/man1/litterbox.1
+@man man/man1/scoop.1
+@man man/man1/unscoop.1
diff --git a/OpenBSD/net/pounce-notify/Makefile b/OpenBSD/net/pounce-notify/Makefile
new file mode 100644
index 0000000..b1d9bf7
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/Makefile
@@ -0,0 +1,33 @@
+COMMENT =	notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-notify-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/notify
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-notify/distinfo b/OpenBSD/net/pounce-notify/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-notify/pkg/DESCR b/OpenBSD/net/pounce-notify/pkg/DESCR
new file mode 100644
index 0000000..dfd2aec
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/DESCR
@@ -0,0 +1 @@
+pounce-notify provides generic notifications for pounce.
diff --git a/OpenBSD/net/pounce-notify/pkg/PLIST b/OpenBSD/net/pounce-notify/pkg/PLIST
new file mode 100644
index 0000000..dd7566e
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-notify
+@man man/man1/pounce-notify.1
diff --git a/OpenBSD/net/pounce-palaver/Makefile b/OpenBSD/net/pounce-palaver/Makefile
new file mode 100644
index 0000000..e3e9d8f
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/Makefile
@@ -0,0 +1,35 @@
+COMMENT =	Palaver push notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-palaver-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c curl sqlite3 tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/palaver
+
+LIB_DEPENDS =	databases/sqlite3 net/curl
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-palaver/distinfo b/OpenBSD/net/pounce-palaver/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-palaver/pkg/DESCR b/OpenBSD/net/pounce-palaver/pkg/DESCR
new file mode 100644
index 0000000..f65a58d
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/DESCR
@@ -0,0 +1,2 @@
+pounce-palaver provides push notifications for the Palaver IRC app
+via pounce.
diff --git a/OpenBSD/net/pounce-palaver/pkg/PLIST b/OpenBSD/net/pounce-palaver/pkg/PLIST
new file mode 100644
index 0000000..d5efc2c
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-palaver
+@man man/man1/pounce-palaver.1
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..34c8628
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,29 @@
+COMMENT =	multi-client, TLS-only IRC bouncer
+
+DISTNAME =	pounce-3.0
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	Omar Polo <op@omarpolo.com>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce/distinfo b/OpenBSD/net/pounce/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce/pkg/DESCR b/OpenBSD/net/pounce/pkg/DESCR
new file mode 100644
index 0000000..6858864
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/DESCR
@@ -0,0 +1,7 @@
+pounce is a multi-client, TLS-only IRC bouncer.  It maintains a
+persistent connection to an IRC server, acting as a proxy and buffer
+for a number of clients.  When a client connects, any messages
+received since it last disconnected will be relayed to it.  Unlike
+some other bouncers, pounce uses a single buffer for all IRC messages,
+which acts as a queue from which each client reads messages
+independently.
diff --git a/OpenBSD/net/pounce/pkg/PLIST b/OpenBSD/net/pounce/pkg/PLIST
new file mode 100644
index 0000000..4616553
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/PLIST
@@ -0,0 +1,4 @@
+@bin bin/calico
+@bin bin/pounce
+@man man/man1/calico.1
+@man man/man1/pounce.1
diff --git a/OpenBSD/sysutils/catsit/Makefile b/OpenBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..eda5576
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/Makefile
@@ -0,0 +1,25 @@
+# $OpenBSD$
+
+COMMENT =	process supervisor
+DISTNAME =	catsit-1.4
+CATEGORIES =	sysutils
+HOMEPAGE =	https://git.causal.agency/catsit/about/
+MAINTAINER =		june@causal.agency
+
+# AGPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB =		c
+
+SITES =		https://git.causal.agency/catsit/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/sysutils/catsit/distinfo b/OpenBSD/sysutils/catsit/distinfo
new file mode 100644
index 0000000..f88d44d
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (catsit-1.4.tar.gz) = gybvLpMSCSzfEhxro997k/gij8pbUU5rBbmMhIU15Ng=
+SIZE (catsit-1.4.tar.gz) = 24341
diff --git a/OpenBSD/sysutils/catsit/pkg/DESCR b/OpenBSD/sysutils/catsit/pkg/DESCR
new file mode 100644
index 0000000..3b65708
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/pkg/DESCR
@@ -0,0 +1,5 @@
+catsit is a process supervisor for FreeBSD and OpenBSD.  The catsitd
+daemon spawns processes for a list of services, redirects their
+output to syslog, and restarts the processes when they exit according
+to their exit status.  Exponential backoff is applied to automatic
+restarts.
diff --git a/OpenBSD/sysutils/catsit/pkg/PLIST b/OpenBSD/sysutils/catsit/pkg/PLIST
new file mode 100644
index 0000000..bf46141
--- /dev/null
+++ b/OpenBSD/sysutils/catsit/pkg/PLIST
@@ -0,0 +1,11 @@
+@comment $OpenBSD: PLIST,v$
+@rcscript ${RCDIR}/catsitd
+@bin bin/catsit-timer
+@bin bin/catsit-watch
+@man man/man1/catsit-timer.1
+@man man/man1/catsit-watch.1
+@man man/man5/catsit.conf.5
+@man man/man8/catsit.8
+@man man/man8/catsitd.8
+sbin/catsit
+@bin sbin/catsitd
diff --git a/OpenBSD/www/cgit-pink/Makefile b/OpenBSD/www/cgit-pink/Makefile
new file mode 100644
index 0000000..1eb163b
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/Makefile
@@ -0,0 +1,39 @@
+# $OpenBSD: Makefile,v 1.27 2020/04/04 19:28:31 kn Exp $
+
+COMMENT =	web frontend for git repositories
+
+DISTNAME =	cgit-pink-1.4.1
+CATEGORIES =	www devel
+
+DISTFILES =	${DISTNAME}.tar.gz
+DISTFILES.git = git-2.36.1.tar.gz
+
+SITES =		https://git.causal.agency/cgit-pink/snapshot/
+SITES.git =		https://www.kernel.org/pub/software/scm/git/
+HOMEPAGE =		https://git.causal.agency/cgit-pink/about/
+
+# GPLv2
+PERMIT_PACKAGE =	Yes
+
+USE_GMAKE =	yes
+
+BUILD_DEPENDS =	textproc/asciidoc
+LIB_DEPENDS =	converters/libiconv
+
+PREFIX =	${VARBASE}/www
+MAKE_FLAGS +=	V=1 NO_GETTEXT=1 EXTRA_GIT_TARGETS='git git-http-backend' LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
+
+ALL_TARGET =	all doc-man
+
+post-extract:
+	rmdir ${WRKSRC}/git
+	mv ${WRKDIR}/git-* ${WRKSRC}/git
+
+post-install:
+	mv ${PREFIX}/htdocs ${PREFIX}/cgit
+	${INSTALL_MAN} ${WRKBUILD}/cgitrc.5 ${WRKINST}${LOCALBASE}/man/man5
+	${INSTALL_PROGRAM_DIR} ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git-http-backend ${PREFIX}/cgi-bin
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/www/cgit-pink/distinfo b/OpenBSD/www/cgit-pink/distinfo
new file mode 100644
index 0000000..77e9a19
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/distinfo
@@ -0,0 +1,4 @@
+SHA256 (cgit-pink-1.4.1.tar.gz) = 8SRsbIEwWADCTn7uKyJDGateV7HdsHtIg66oRfKQRtU=
+SHA256 (git-2.36.1.tar.gz) = N9k2/RfIGqnd09uk5W6IpF+lNK0LqUZFTozoGHYMaiw=
+SIZE (cgit-pink-1.4.1.tar.gz) = 104130
+SIZE (git-2.36.1.tar.gz) = 10699999
diff --git a/OpenBSD/www/cgit-pink/patches/patch-Makefile b/OpenBSD/www/cgit-pink/patches/patch-Makefile
new file mode 100644
index 0000000..b49eb37
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-Makefile
@@ -0,0 +1,30 @@
+$OpenBSD: patch-Makefile,v 1.9 2018/08/04 09:19:35 kn Exp $
+Index: Makefile
+--- Makefile.orig
++++ Makefile
+@@ -2,11 +2,11 @@ all::
+ 
+ CGIT_VERSION = v1.2.1
+ CGIT_SCRIPT_NAME = cgit.cgi
+-CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
+-CGIT_DATA_PATH = $(CGIT_SCRIPT_PATH)
+-CGIT_CONFIG = /etc/cgitrc
+-CACHE_ROOT = /var/cache/cgit
+-prefix = /usr/local
++CGIT_SCRIPT_PATH = /var/www/cgi-bin
++CGIT_DATA_PATH = /var/www/htdocs
++CGIT_CONFIG = /conf/cgitrc
++CACHE_ROOT = /tmp/cgit
++prefix = ${PREFIX}
+ libdir = $(prefix)/lib
+ filterdir = $(libdir)/cgit/filters
+ docdir = $(prefix)/share/doc/cgit
+@@ -90,8 +90,6 @@ install: all
+ 	$(INSTALL) -m 0644 cgit.png $(DESTDIR)$(CGIT_DATA_PATH)/cgit.png
+ 	$(INSTALL) -m 0644 favicon.ico $(DESTDIR)$(CGIT_DATA_PATH)/favicon.ico
+ 	$(INSTALL) -m 0644 robots.txt $(DESTDIR)$(CGIT_DATA_PATH)/robots.txt
+-	$(INSTALL) -m 0755 -d $(DESTDIR)$(filterdir)
+-	$(COPYTREE) filters/* $(DESTDIR)$(filterdir)
+ 
+ install-doc: install-man install-html install-pdf
+ 
diff --git a/OpenBSD/www/cgit-pink/patches/patch-cgit_mk b/OpenBSD/www/cgit-pink/patches/patch-cgit_mk
new file mode 100644
index 0000000..c74f62d
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-cgit_mk
@@ -0,0 +1,11 @@
+$OpenBSD: patch-cgit_mk,v 1.1 2013/07/15 07:00:49 jasper Exp $
+--- cgit.mk.orig	Sun Jul 14 23:18:05 2013
++++ cgit.mk	Sun Jul 14 23:18:39 2013
+@@ -17,6 +17,7 @@ $(CGIT_PREFIX)VERSION: force-version
+ 
+ # CGIT_CFLAGS is a separate variable so that we can track it separately
+ # and avoid rebuilding all of Git when these variables change.
++CGIT_CFLAGS += -L${LOCALBASE}/include
+ CGIT_CFLAGS += -DCGIT_CONFIG='"$(CGIT_CONFIG)"'
+ CGIT_CFLAGS += -DCGIT_SCRIPT_NAME='"$(CGIT_SCRIPT_NAME)"'
+ CGIT_CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
diff --git a/OpenBSD/www/cgit-pink/patches/patch-setup_c b/OpenBSD/www/cgit-pink/patches/patch-setup_c
new file mode 100644
index 0000000..eae3fc0
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/patches/patch-setup_c
@@ -0,0 +1,20 @@
+$OpenBSD: patch-setup_c,v 1.1 2017/03/22 20:23:52 landry Exp $
+
+Dont openbsd dev/null, doesnt exist in the default chroot
+
+--- git/setup.c.orig	Wed Mar  1 21:01:06 2017
++++ git/setup.c	Wed Mar  1 21:01:56 2017
+@@ -1488,11 +1488,13 @@ const char *resolve_gitdir_gently(const char *suspect, int *return_error_code)
+ /* if any standard file descriptor is missing open it to /dev/null */
+ void sanitize_stdfds(void)
+ {
++#if 0
+ 	int fd = xopen("/dev/null", O_RDWR);
+ 	while (fd < 2)
+ 		fd = xdup(fd);
+ 	if (fd > 2)
+ 		close(fd);
++#endif
+ }
+ 
+ int daemonize(void)
diff --git a/OpenBSD/www/cgit-pink/pkg/DESCR b/OpenBSD/www/cgit-pink/pkg/DESCR
new file mode 100644
index 0000000..f85c78a
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/pkg/DESCR
@@ -0,0 +1,2 @@
+This is an attempt to create a fast web interface for the git scm,
+using a builtin cache to decrease server io-pressure.
diff --git a/OpenBSD/www/cgit-pink/pkg/PLIST b/OpenBSD/www/cgit-pink/pkg/PLIST
new file mode 100644
index 0000000..aeb2763
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/pkg/PLIST
@@ -0,0 +1,14 @@
+@comment $OpenBSD: PLIST,v 1.6 2018/09/04 12:46:24 espie Exp $
+@conflict cgit-*
+@group daemon
+@bin bin/git
+@bin cgi-bin/cgit.cgi
+@bin cgi-bin/git-http-backend
+@group
+cgit/
+cgit/cgit.css
+cgit/cgit.png
+cgit/robots.txt
+@cwd ${LOCALBASE}
+@man man/man5/cgitrc.5
+share/doc/pkg-readmes/${PKGSTEM}
diff --git a/OpenBSD/www/cgit-pink/pkg/README b/OpenBSD/www/cgit-pink/pkg/README
new file mode 100644
index 0000000..816ad9e
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/pkg/README
@@ -0,0 +1,74 @@
+$OpenBSD: README,v 1.5 2018/09/04 12:46:24 espie Exp $
+
++-----------------------------------------------------------------------
+| Running ${PKGSTEM} on OpenBSD
++-----------------------------------------------------------------------
+
+Cgit config
+===========
+By default, the cgitrc config file is searched in ${PREFIX}/conf/cgitrc.
+Refer to cgitrc(5) for the syntax.
+
+Webserver config
+================
+
+OpenBSD httpd
+-------------
+server "default" {
+	listen on egress port 80
+
+	# don't serve static files from cgit CGI: cgit.css and cgit.png
+	location "/cgit.*" {
+		root "/cgit"
+		no fastcgi
+	}
+	root "/cgi-bin/cgit.cgi"
+	fastcgi socket "/run/slowcgi.sock"
+}
+
+Nginx
+-----
+An example nginx config snippet is provided below, to run with
+slowcgi:
+
+server {
+	server_name cgit.example.com;
+	access_log logs/cgit-access main;
+	error_log logs/cgit-error warn;
+	location ~ /cgit.(png|css) {
+		root /var/www/htdocs;
+	}
+	location / {
+		rewrite /(.*) /cgi-bin/cgit.cgi/$1;
+	}
+	location /cgi-bin/ {
+		fastcgi_pass unix:run/slowcgi.sock;
+		fastcgi_split_path_info ^(/cgi-bin/[^/]+)(.*);
+		fastcgi_param  PATH_INFO $fastcgi_path_info;
+		include fastcgi_params;
+	}
+}
+
+Apache config
+-------------
+
+This config snippet works with Apache:
+
+ScriptAlias /cgit /cgi-bin/cgit.cgi
+<Location "/cgit">
+	AllowOverride None
+	Options +ExecCGI
+	Order allow,deny
+	Allow from all
+</Location>
+
+
+snapshots
+---------
+Nginx and OpenBSD httpd use chroot(2).
+
+For .tar.gz snapshot support a static binary in $chroot/bin/gzip is required.
+
+	cd /usr/src/usr.bin/compress
+	make clean && make LDFLAGS="-static -pie"
+	cp obj/compress $chroot/bin/gzip