summary refs log tree commit diff
path: root/irc/pounce-notify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/pounce-notify/Makefile')
-rw-r--r--irc/pounce-notify/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/irc/pounce-notify/Makefile b/irc/pounce-notify/Makefile
new file mode 100644
index 0000000..f19cdd8
--- /dev/null
+++ b/irc/pounce-notify/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.4
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Generic notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/notify
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-notify \
+		man/man1/pounce-notify.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-notify
+
+.include <bsd.port.mk>