summary refs log tree commit diff
path: root/irc/pounce-notify
diff options
context:
space:
mode:
Diffstat (limited to 'irc/pounce-notify')
-rw-r--r--irc/pounce-notify/Makefile28
-rw-r--r--irc/pounce-notify/distinfo3
-rw-r--r--irc/pounce-notify/pkg-descr3
3 files changed, 34 insertions, 0 deletions
diff --git a/irc/pounce-notify/Makefile b/irc/pounce-notify/Makefile
new file mode 100644
index 0000000..f19cdd8
--- /dev/null
+++ b/irc/pounce-notify/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.4
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Generic notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	extra/notify
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-notify \
+		man/man1/pounce-notify.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-notify
+
+.include <bsd.port.mk>
diff --git a/irc/pounce-notify/distinfo b/irc/pounce-notify/distinfo
new file mode 100644
index 0000000..8900717
--- /dev/null
+++ b/irc/pounce-notify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622136116
+SHA256 (pounce-2.4.tar.gz) = 0fe406700a80798eb669db90bef73cc4a644a29a2a36ea7178fed73623050a21
+SIZE (pounce-2.4.tar.gz) = 51453
diff --git a/irc/pounce-notify/pkg-descr b/irc/pounce-notify/pkg-descr
new file mode 100644
index 0000000..4b2437a
--- /dev/null
+++ b/irc/pounce-notify/pkg-descr
@@ -0,0 +1,3 @@
+Generic notification provider for the pounce IRC bouncer.
+
+WWW: https://git.causal.agency/pounce/