summary refs log tree commit diff
path: root/irc/pounce/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 18:46:51 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 18:48:00 +0000
commit53301b81f62359dc647e8f1fe22f0e1b456e818f (patch)
tree101bf07033c4aad06305a52a691b7a36c3ce143c /irc/pounce/Makefile
parentIgnore work directories (diff)
downloadports-53301b81f62359dc647e8f1fe22f0e1b456e818f.tar.gz
ports-53301b81f62359dc647e8f1fe22f0e1b456e818f.zip
Add pounce port
Diffstat (limited to 'irc/pounce/Makefile')
-rw-r--r--irc/pounce/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/irc/pounce/Makefile b/irc/pounce/Makefile
new file mode 100644
index 0000000..6a5c656
--- /dev/null
+++ b/irc/pounce/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME=	pounce
+DISTVERSION=	1.3p1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>