summary refs log tree commit diff
path: root/FreeBSD/irc/pounce/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
committerJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
commit97eb0074b135b2636d84ff503988e3d76803ddcc (patch)
treeb7bf84cab6a5df4035634f60e4b92ed8dbcf8c32 /FreeBSD/irc/pounce/Makefile
parentUpdate catsit to 1.4 (diff)
downloadports-97eb0074b135b2636d84ff503988e3d76803ddcc.tar.gz
ports-97eb0074b135b2636d84ff503988e3d76803ddcc.zip
Move FreeBSD ports under FreeBSD directory
Diffstat (limited to 'FreeBSD/irc/pounce/Makefile')
-rw-r--r--FreeBSD/irc/pounce/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/FreeBSD/irc/pounce/Makefile b/FreeBSD/irc/pounce/Makefile
new file mode 100644
index 0000000..92c806a
--- /dev/null
+++ b/FreeBSD/irc/pounce/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	pounce
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/calico \
+		bin/pounce \
+		man/man1/calico.1.gz \
+		man/man1/pounce.1.gz
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>