summary refs log tree commit diff
path: root/OpenBSD/net/bubger/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net/bubger/Makefile')
-rw-r--r--OpenBSD/net/bubger/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/OpenBSD/net/bubger/Makefile b/OpenBSD/net/bubger/Makefile
new file mode 100644
index 0000000..69a8e74
--- /dev/null
+++ b/OpenBSD/net/bubger/Makefile
@@ -0,0 +1,30 @@
+COMMENT =	IMAP archive generator
+
+DISTNAME =	bubger-1.1
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/bubger/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+LIB_DEPENDS =	converters/libiconv
+
+SITES =		https://git.causal.agency/bubger/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>