summary refs log tree commit diff
path: root/OpenBSD/net
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net')
-rw-r--r--OpenBSD/net/bubger/Makefile30
-rw-r--r--OpenBSD/net/bubger/distinfo2
-rw-r--r--OpenBSD/net/bubger/pkg/DESCR4
-rw-r--r--OpenBSD/net/bubger/pkg/PLIST3
-rw-r--r--OpenBSD/net/litterbox/Makefile27
-rw-r--r--OpenBSD/net/litterbox/distinfo2
-rw-r--r--OpenBSD/net/litterbox/pkg/DESCR4
-rw-r--r--OpenBSD/net/litterbox/pkg/PLIST7
-rw-r--r--OpenBSD/net/pounce-notify/Makefile33
-rw-r--r--OpenBSD/net/pounce-notify/distinfo2
-rw-r--r--OpenBSD/net/pounce-notify/pkg/DESCR1
-rw-r--r--OpenBSD/net/pounce-notify/pkg/PLIST2
-rw-r--r--OpenBSD/net/pounce-palaver/Makefile35
-rw-r--r--OpenBSD/net/pounce-palaver/distinfo2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/DESCR2
-rw-r--r--OpenBSD/net/pounce-palaver/pkg/PLIST2
-rw-r--r--OpenBSD/net/pounce/Makefile29
-rw-r--r--OpenBSD/net/pounce/distinfo2
-rw-r--r--OpenBSD/net/pounce/pkg/DESCR7
-rw-r--r--OpenBSD/net/pounce/pkg/PLIST4
20 files changed, 200 insertions, 0 deletions
diff --git a/OpenBSD/net/bubger/Makefile b/OpenBSD/net/bubger/Makefile
new file mode 100644
index 0000000..69a8e74
--- /dev/null
+++ b/OpenBSD/net/bubger/Makefile
@@ -0,0 +1,30 @@
+COMMENT =	IMAP archive generator
+
+DISTNAME =	bubger-1.1
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/bubger/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+LIB_DEPENDS =	converters/libiconv
+
+SITES =		https://git.causal.agency/bubger/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/bubger/distinfo b/OpenBSD/net/bubger/distinfo
new file mode 100644
index 0000000..fb1a071
--- /dev/null
+++ b/OpenBSD/net/bubger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bubger-1.1.tar.gz) = hnt8BVougThOm83NEuzzjA54iR6XaLaXh1VH4M5NmQQ=
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/OpenBSD/net/bubger/pkg/DESCR b/OpenBSD/net/bubger/pkg/DESCR
new file mode 100644
index 0000000..fb62e9f
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/DESCR
@@ -0,0 +1,4 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access.  It requires the
+IMAP THREAD extension.
diff --git a/OpenBSD/net/bubger/pkg/PLIST b/OpenBSD/net/bubger/pkg/PLIST
new file mode 100644
index 0000000..2803d1c
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/PLIST
@@ -0,0 +1,3 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/bubger
+@man man/man1/bubger.1
diff --git a/OpenBSD/net/litterbox/Makefile b/OpenBSD/net/litterbox/Makefile
new file mode 100644
index 0000000..6a9f64a
--- /dev/null
+++ b/OpenBSD/net/litterbox/Makefile
@@ -0,0 +1,27 @@
+# $OpenBSD$
+
+COMMENT =	IRC logger
+DISTNAME =	litterbox-1.8
+CATEGORIES =	net
+HOMEPAGE =	https://git.causal.agency/litterbox/about/
+MAINTAINER =		june@causal.agency
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+WANTLIB =		c sqlite3 tls
+LIB_DEPENDS =	databases/sqlite3
+
+SITES =		https://git.causal.agency/litterbox/snapshot/
+
+# C11
+COMPILER =	base-clang ports-gcc
+COMPILER_LANGS =	c
+
+NO_TEST =		Yes
+
+CFLAGS +=	-I${LOCALBASE}/include
+MAKE_FLAGS +=	LDFLAGS=-L${LOCALBASE}/lib
+FAKE_FLAGS =	PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/litterbox/distinfo b/OpenBSD/net/litterbox/distinfo
new file mode 100644
index 0000000..d8a3759
--- /dev/null
+++ b/OpenBSD/net/litterbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (litterbox-1.8.tar.gz) = VL68N1DzkIE6NyDrAwGsTYUrMMt7dgWxeO1ZqlFohVI=
+SIZE (litterbox-1.8.tar.gz) = 36827
diff --git a/OpenBSD/net/litterbox/pkg/DESCR b/OpenBSD/net/litterbox/pkg/DESCR
new file mode 100644
index 0000000..c50791d
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/DESCR
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger.  It logs events from IRC in a
+SQLite database, indexing messages for full-text search.  It is
+intended for use with the IRC bouncer pounce, but can also be used
+independently as a logging bot.
diff --git a/OpenBSD/net/litterbox/pkg/PLIST b/OpenBSD/net/litterbox/pkg/PLIST
new file mode 100644
index 0000000..606da42
--- /dev/null
+++ b/OpenBSD/net/litterbox/pkg/PLIST
@@ -0,0 +1,7 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/litterbox
+@bin bin/scoop
+@bin bin/unscoop
+@man man/man1/litterbox.1
+@man man/man1/scoop.1
+@man man/man1/unscoop.1
diff --git a/OpenBSD/net/pounce-notify/Makefile b/OpenBSD/net/pounce-notify/Makefile
new file mode 100644
index 0000000..b1d9bf7
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/Makefile
@@ -0,0 +1,33 @@
+COMMENT =	notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-notify-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/notify
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-notify/distinfo b/OpenBSD/net/pounce-notify/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-notify/pkg/DESCR b/OpenBSD/net/pounce-notify/pkg/DESCR
new file mode 100644
index 0000000..dfd2aec
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/DESCR
@@ -0,0 +1 @@
+pounce-notify provides generic notifications for pounce.
diff --git a/OpenBSD/net/pounce-notify/pkg/PLIST b/OpenBSD/net/pounce-notify/pkg/PLIST
new file mode 100644
index 0000000..dd7566e
--- /dev/null
+++ b/OpenBSD/net/pounce-notify/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-notify
+@man man/man1/pounce-notify.1
diff --git a/OpenBSD/net/pounce-palaver/Makefile b/OpenBSD/net/pounce-palaver/Makefile
new file mode 100644
index 0000000..e3e9d8f
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/Makefile
@@ -0,0 +1,35 @@
+COMMENT =	Palaver push notifications for pounce
+
+VERSION =	3.0
+DISTNAME =	pounce-${VERSION}
+PKGNAME =	pounce-palaver-${VERSION}
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c curl sqlite3 tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+WRKSRC =	${WRKDIST}/extra/palaver
+
+LIB_DEPENDS =	databases/sqlite3 net/curl
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce-palaver/distinfo b/OpenBSD/net/pounce-palaver/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce-palaver/pkg/DESCR b/OpenBSD/net/pounce-palaver/pkg/DESCR
new file mode 100644
index 0000000..f65a58d
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/DESCR
@@ -0,0 +1,2 @@
+pounce-palaver provides push notifications for the Palaver IRC app
+via pounce.
diff --git a/OpenBSD/net/pounce-palaver/pkg/PLIST b/OpenBSD/net/pounce-palaver/pkg/PLIST
new file mode 100644
index 0000000..d5efc2c
--- /dev/null
+++ b/OpenBSD/net/pounce-palaver/pkg/PLIST
@@ -0,0 +1,2 @@
+@bin bin/pounce-palaver
+@man man/man1/pounce-palaver.1
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..34c8628
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,29 @@
+COMMENT =	multi-client, TLS-only IRC bouncer
+
+DISTNAME =	pounce-3.0
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	Omar Polo <op@omarpolo.com>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce/distinfo b/OpenBSD/net/pounce/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce/pkg/DESCR b/OpenBSD/net/pounce/pkg/DESCR
new file mode 100644
index 0000000..6858864
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/DESCR
@@ -0,0 +1,7 @@
+pounce is a multi-client, TLS-only IRC bouncer.  It maintains a
+persistent connection to an IRC server, acting as a proxy and buffer
+for a number of clients.  When a client connects, any messages
+received since it last disconnected will be relayed to it.  Unlike
+some other bouncers, pounce uses a single buffer for all IRC messages,
+which acts as a queue from which each client reads messages
+independently.
diff --git a/OpenBSD/net/pounce/pkg/PLIST b/OpenBSD/net/pounce/pkg/PLIST
new file mode 100644
index 0000000..4616553
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/PLIST
@@ -0,0 +1,4 @@
+@bin bin/calico
+@bin bin/pounce
+@man man/man1/calico.1
+@man man/man1/pounce.1