summary refs log tree commit diff
path: root/OpenBSD/net/pounce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net/pounce/Makefile')
-rw-r--r--OpenBSD/net/pounce/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..34c8628
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,29 @@
+COMMENT =	multi-client, TLS-only IRC bouncer
+
+DISTNAME =	pounce-3.0
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	Omar Polo <op@omarpolo.com>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>