summary refs log tree commit diff
path: root/OpenBSD/net/pounce
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/net/pounce')
-rw-r--r--OpenBSD/net/pounce/Makefile29
-rw-r--r--OpenBSD/net/pounce/distinfo2
-rw-r--r--OpenBSD/net/pounce/pkg/DESCR7
-rw-r--r--OpenBSD/net/pounce/pkg/PLIST4
4 files changed, 42 insertions, 0 deletions
diff --git a/OpenBSD/net/pounce/Makefile b/OpenBSD/net/pounce/Makefile
new file mode 100644
index 0000000..34c8628
--- /dev/null
+++ b/OpenBSD/net/pounce/Makefile
@@ -0,0 +1,29 @@
+COMMENT =	multi-client, TLS-only IRC bouncer
+
+DISTNAME =	pounce-3.0
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/pounce/about/
+
+MAINTAINER =	Omar Polo <op@omarpolo.com>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+
+SITES =		https://git.causal.agency/pounce/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/pounce/distinfo b/OpenBSD/net/pounce/distinfo
new file mode 100644
index 0000000..d901dd3
--- /dev/null
+++ b/OpenBSD/net/pounce/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pounce-3.0.tar.gz) = 93b38XBJNpepeSPn3OlZff9Vd/1AunVumhvPqxcZnfA=
+SIZE (pounce-3.0.tar.gz) = 50497
diff --git a/OpenBSD/net/pounce/pkg/DESCR b/OpenBSD/net/pounce/pkg/DESCR
new file mode 100644
index 0000000..6858864
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/DESCR
@@ -0,0 +1,7 @@
+pounce is a multi-client, TLS-only IRC bouncer.  It maintains a
+persistent connection to an IRC server, acting as a proxy and buffer
+for a number of clients.  When a client connects, any messages
+received since it last disconnected will be relayed to it.  Unlike
+some other bouncers, pounce uses a single buffer for all IRC messages,
+which acts as a queue from which each client reads messages
+independently.
diff --git a/OpenBSD/net/pounce/pkg/PLIST b/OpenBSD/net/pounce/pkg/PLIST
new file mode 100644
index 0000000..4616553
--- /dev/null
+++ b/OpenBSD/net/pounce/pkg/PLIST
@@ -0,0 +1,4 @@
+@bin bin/calico
+@bin bin/pounce
+@man man/man1/calico.1
+@man man/man1/pounce.1
667a929fd2667ecf2ca9e&follow=1'>Add gzgets.3June McEnroe 2018-11-13Add gzputs.3June McEnroe 2018-11-13Add gzprintf.3June McEnroe 2018-11-13Add gzfwrite.3June McEnroe 2018-11-13Add gzwrite.3June McEnroe 2018-11-12Add gzfread.3June McEnroe 2018-11-12Add gzread.3June McEnroe 2018-11-12Add gzsetparams.3June McEnroe 2018-11-12Add gzbuffer.3June McEnroe 2018-11-12Add gzdopen to gzopen.3June McEnroe 2018-11-12Add gzopen.3June McEnroe 2018-11-12Add inflateBackEnd.3June McEnroe 2018-11-12Add inflateBack.3June McEnroe 2018-11-12Add inflateBackInit.3June McEnroe 2018-11-11Add inflateGetHeader.3June McEnroe 2018-11-11Add inflateMark.3June McEnroe 2018-11-11Add inflatePrime.3June McEnroe 2018-11-11Add inflateReset.3June McEnroe 2018-11-11Add inflateCopy.3June McEnroe 2018-11-11Add inflateSync.3June McEnroe 2018-11-11Add inflateGetDictionary.3June McEnroe 2018-11-11Add inflateSetDictionary.3June McEnroe 2018-11-11Add inflateInit2.3June McEnroe